Bug details

Fonts not loading from Font Managers

About my Computer:
Surface Pro 2017 i7 16GBram
Windows 10 Version 1703 Build 15063.540

1. Experience Design CC (Beta) v. 0.8.22

2. Launch a Font Manager (Fontbase or NexusFont), Open existing or new project in XD, Select existing text or create new text, click on font list dropdown on XD.

3. Fonts loaded on Font Manager (Fontbase or NexusFont) SHOULD appear in the font list dropdown in XD.

4. Fonts loaded on Font Manager (Fontbase or NexusFont) DOES NOT appear in the font list dropdown in XD.

81 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Michael Gorospe shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    59 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        I have the same problem with Adobe Xd and the font manager NexusFont. The weird thing is my colleagues in my agency use the exact same font manager but don't have that problem at all. I tried reinstalling Adobe Xd but didn't change a thing. Please fix this.

      • Airwrecka Wagner commented  ·   ·  Flag as inappropriate

        Same Issue here.
        I work with a lot of clients and therefore use a lot of different fonts. It's important that I use a fontmanager(fontbase, typograf) to activate just the fonts that I need, otherwise my PC would not run smoothly. Other Adobe Products are able to detect the fonts from the fontmanager, which even is installed on another hard drive.
        Until you resolve this problem we can't successfully introduce XD in our company.

      • Francisco M. Ferreiro commented  ·   ·  Flag as inappropriate

        Same issue. Using Suitcase Fusion 19.0.5.6523. Fonts work fine in other Adobe program, even without Extensis plug-ins.
        This bug was posted 8 months ago!
        I can't believe it took that long to acknowledge the bug. Who are your users? Do you test the products? Do you understand how designers work?
        It's incredibly irritating to find so many discrepancies all the time between Adobe products. Do you guys even use your own products? 🤦‍♂️

      • Brett Wood commented  ·   ·  Flag as inappropriate

        A workaround that works for me with Fontbase is to restart my PC, then start fontbase up right away, before Adobe XD. Adobe XD will load the fonts when opening. Unfortunately if I add new fonts, I have to restart the PC again if I want them to show up in XD :(. But I guess at least it works . . .

      • Marc Robinson commented  ·   ·  Flag as inappropriate

        I have encountered countless stupid omissions in XD but this is by far one of the worst. Real designers will use font managers and most likely don't install fonts in the windows folder because at some point they figured out that windows will mess up your fonts.

        Also, did the the note that said "IMPLEMENT TABS!!!" fall off the table at some meeting? Photoshop has tabs, illustrator has tabs... dumb XD has a window for each file...

      • Jan commented  ·   ·  Flag as inappropriate

        Same issue here. Really annoying to have to manually activate fonts when those same fonts work fine in InDesign, Photoshop and even on paper.

        Windows build: Running on Windows 10 17133.1 (though I have that appearing also on 1703 and pretty much every build since Mid 2017).
        XD version: Everyone since mid 2017.
        Font manager: FontBase, Suitcase Fusion
        Acquired from: FontAwesome, myfonts, Google Fonts, anything really.

      • Hill Steed commented  ·   ·  Flag as inappropriate

        Are there any updates or new progress to report on this? Having to uninstall and reinstall fonts anytime I want to use XD works, but also disrupts workflow enough that it becomes quite frustrating. Also, does this create any issues around interoperability? I'm a recent Mac to PC convert but work with teams using both platforms. Please advise, thank you!

      • Harold commented  ·   ·  Flag as inappropriate

        Currently on Windows 10 (Fall 2017 Creators Update), running "Extensis Suitcase Fusion 8" as my font manager. Unfortunately as others have mentioned most Font managers will NOT work "only" when using Adobe XD, all other applications work just fine.

        Not being able to load and activate fonts using a font manager has become a real hindrance issue, specially as Adobe XD is being used more and more, with newer more finished features, that make it a real viable one stop solution. Managing fonts for different clients & accounts in a design production environment is something done every day with thousands of fonts. Many of us, and many agencies manage fonts this way.

        Unfortunately removing and reinstalling fonts from our systems does not resolve the problem with font managers (regardless of how it's done and setup). Installing fonts without the font manager to the default Windows font folder works, however it is not really a viable temporary solution either, as things can easily get out of hand with thousands of different client fonts & accounts.

        I'm hoping this can soon be fixed either on Microsoft's end, or Adobe should Microsoft not address the UWP bug.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Status update on this? I think many people would like this to be resolved so we can continue to use Adobe XD effectively.

        Thanks

      • Touit commented  ·   ·  Flag as inappropriate

        Having similar problems with Tisa Pro. The font is synced and works well in Illustrator, but XD doesn't show the regular bold version. When selected, it shows italic bold. Very annoying.

      • Antti Laitinen commented  ·   ·  Flag as inappropriate

        Hi,

        I'm struggling here with exactly the same problem. I use Fontbase (Windows 10) to manage all my font files so I don't have to install, remove and reinstall thousands of fonts in Windows system directory. I find it quite unbelievable that professional design software doesn't work with fonts. And even more so because all other Adobe programs work without any issues.

        Is there any information on when this problem could be fixed? This affects my business and workflow on so many levels.

        Best regards,
        Antti

      • Jakub commented  ·   ·  Flag as inappropriate

        Same issue (Suitcase Fusion 8). Some fonts are missing in XD. They are avaliable in other CC apps.

      • Wilbert commented  ·   ·  Flag as inappropriate

        Hi there,
        Same issue here. Fonts in Fontbase load as usual in Indesign, Photoshop and Illustrator. But not in XD. I definately do not want to install 1000+ fonts in my system directory.

      • Michael Gorospe commented  ·   ·  Flag as inappropriate

        Hello, thanks for your response. To answer your questions,

        1. I don't install fonts physically in the Windows System Fonts directory. I just use Fontbase for installing fonts that I need.

        2. Running Fontbase with the activated fonts that I need, shows up in other Adobe applications like Illustrator and Photoshop, same are Microsoft Word.

        3. I have tried this experiment of restarting the computer before running fontbase again and then running XD with no success.

        4. I don't install the fonts physically in the windows system fonts directory, so I think that this should not be a problem.

        A TEST THAT WORKED:
        The font needs to be physically installed in the in the Windows System Fonts directory. I see this as not a good option and definitely a last resort.

        Thank you for following up. I hope that you guys figure out what causes this issue in XD windows10

        Sincerely,
        Michael

      • Andrew commented  ·   ·  Flag as inappropriate

        Some synced typekit fonts won't work properly. In this example, I've synced the Urbana font, however when I select that font in XD, there are issues.

        The font styles only sometimes work. Most of the time the text doesn't change. You can see in the images attached how urbana doesn't show up as a single font to select, with multiple font styles. Instead it shows up as separate fonts. Selecting urbana semibolditalic for example doesn't change the text.

        It's not only with this font. I have had similar issues with other fonts from typekit.

        XD Version: 0.6.32.12

      1 3 Next →

      Feedback and Knowledge Base