Adobe XD: Bugs

When filing a new bug, please provide:

  1. Version of Adobe XD
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. XD file, video or GIF capturing the issue (optional)

XD Known Issues list,
https://helpx.adobe.com/sea/xd/kb/known-issues.html#main-pars_text_2544517

Thank you.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. [Win10] Application stops responding (keyboard)

    Version 9.1.12.3
    Creative Cloud Sync 3.0.3.6
    Windows 10 PRO · Version 1709
    Lenovo X1 Carbon i7-6500 · 8 GB

    Xd succesfully launch, but after a while (randomly between 10" ~ 5') the keyboard stops working. Not writing in text fields, not editing any UI field, not shortcuts. I have to close the program and launch it again.

    Please, fix this problem because further than annoying, it makes really difficult to continue working with this fantastic app.

    Thank you,

    Francesc

    314 votes
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)

      We’ll send you updates on this idea

      awaiting-external-fix  ·  247 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
    • Fonts not loading from Font Managers

      About my Computer:
      Surface Pro 2017 i7 16GBram
      Windows 10 Version 1703 Build 15063.540

      1. Experience Design CC (Beta) v. 0.8.22

      2. Launch a Font Manager (Fontbase or NexusFont), Open existing or new project in XD, Select existing text or create new text, click on font list dropdown on XD.

      3. Fonts loaded on Font Manager (Fontbase or NexusFont) SHOULD appear in the font list dropdown in XD.

      4. Fonts loaded on Font Manager (Fontbase or NexusFont) DOES NOT appear in the font list dropdown in XD.

      49 votes
      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)

        We’ll send you updates on this idea

        45 comments  ·  Flag idea as inappropriate…  ·  Admin →
      • 37 votes
        Sign in
        Check!
        (thinking…)
        Reset
        or sign in with
        • facebook
        • google
          Password icon
          Signed in as (Sign out)

          We’ll send you updates on this idea

          35 comments  ·  Flag idea as inappropriate…  ·  Admin →
        • Sharing error (44:77:0)

          1. 4.0.12.6 (adobe xd), 2.4.4.71 (cloud sync version)
          2. Have a prototype (with single or multiple artboards connected), share the prototype as specs or normal prototype.
          3. Sharing should be succesfull.
          4. Error 44:77:0 is shown.

          Tried multiple times, with smaller and bigger artboards. The error is always the same.

          31 votes
          Sign in
          Check!
          (thinking…)
          Reset
          or sign in with
          • facebook
          • google
            Password icon
            Signed in as (Sign out)

            We’ll send you updates on this idea

            39 comments  ·  Flag idea as inappropriate…  ·  Admin →
          • Can't save project

            <<The document “Untitled 2” could not be saved as “Untitled 2”>>.
            I tried other names and tried saving it to different locations, but it didn't work.

            29 votes
            Sign in
            Check!
            (thinking…)
            Reset
            or sign in with
            • facebook
            • google
              Password icon
              Signed in as (Sign out)

              We’ll send you updates on this idea

              30 comments  ·  Flag idea as inappropriate…  ·  Admin →
            • Undo (cmd + z) stops working

              I have discovered that the undo function (cmd + z) stops working in XD after I have worked on a document for a while. Things that I typically undo is positioning of elements. Undo starts working again if you quit and reopen XD.

              This has happened a few times the last week.

              Environment details:
              - macOS High Sierra Version 10.13.6
              - Adobe XD version 11.0.22.10

              28 votes
              Sign in
              Check!
              (thinking…)
              Reset
              or sign in with
              • facebook
              • google
                Password icon
                Signed in as (Sign out)

                We’ll send you updates on this idea

                23 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
              • 27 votes
                Sign in
                Check!
                (thinking…)
                Reset
                or sign in with
                • facebook
                • google
                  Password icon
                  Signed in as (Sign out)

                  We’ll send you updates on this idea

                  6 comments  ·  Flag idea as inappropriate…  ·  Admin →
                • pdf export blurry images (with shadow) and file size

                  When exporting to pdf, the file size becomes quite huge.
                  Additionally, the images that have a shadow (added in XD, image is jpeg) become blurry and the text (in the image) unreadable. It's no problem without shadow.

                  16 votes
                  Sign in
                  Check!
                  (thinking…)
                  Reset
                  or sign in with
                  • facebook
                  • google
                    Password icon
                    Signed in as (Sign out)

                    We’ll send you updates on this idea

                    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
                  • Proper Object Alignment

                    I often find that when trying to align objects, shapes or even text, no matter what I try, the object won't align to the same edge as something else, despite being the EXACT same width. This is really really annoying, as it's not an issue at all in InDesign or Illustrator. It's the only thing I don't like about XD.

                    When will this issue be fixed?

                    15 votes
                    Sign in
                    Check!
                    (thinking…)
                    Reset
                    or sign in with
                    • facebook
                    • google
                      Password icon
                      Signed in as (Sign out)

                      We’ll send you updates on this idea

                      5 comments  ·  Flag idea as inappropriate…  ·  Admin →
                    • [Win 10] Incorrect display when re-ordering layers

                      windows 10
                      GTX 1080 (latest drivers 399.07).

                      Reordering layers (not only groups) randomly (i'd say 1 every 10 reordering wihtout noticable pattern) leaves a persistent ghost of the dragged item (even outside the application, ie on the desktop) and reordering stops working after that.

                      Ghost is often presented as a slashed red circle within a grey square, in the case of dragging a single layer (screenshot attached)

                      This bug has been present since this feature was introduced in XD.
                      Every session of my work in xd is plagued with this issue.

                      13 votes
                      Sign in
                      Check!
                      (thinking…)
                      Reset
                      or sign in with
                      • facebook
                      • google
                        Password icon
                        Signed in as (Sign out)

                        We’ll send you updates on this idea

                        11 comments  ·  System  ·  Flag idea as inappropriate…  ·  Admin →

                        Thanks for the additional information. There seem to be a number of issues you’re seeing.

                        For layers re-order, there were some improvements incorporated into XD a few builds ago. But sounds like that may not be helping in your case.

                        The biggest culprit for Win10 performance issues in XD is video card incompatibility. For this, verifying that you 1) your card is supported in the Win10 OS you’re working with & 2) you have the latest driver, will address a significant number of issues.

                        To better understand what’s going, having the following helps to narrow things down:
                        - XD version
                        - OS version
                        - video card model & driver version
                        - Is the problem observed in all files? Or just some
                        - How do other UWP apps behave?

                        Thanks!
                        Nina

                      • Unable to reliably sync XD files with CC to team members

                        Hi there.

                        I have a team of multiple users trying to sync folders of XD files up to Creative Cloud and then down to computers so that we can always all have the latest versions of files. This is an integral function for us to have cloud control over our files. We are all located remotely around the world. Over the last few weeks we have all had issues with syncing on and off.

                        ISSUE:
                        - Member 1 adds XD file to CC folder on local machine (or saves file updates).
                        - Member 2,3,4 can see update in Cloud but…

                        13 votes
                        Sign in
                        Check!
                        (thinking…)
                        Reset
                        or sign in with
                        • facebook
                        • google
                          Password icon
                          Signed in as (Sign out)

                          We’ll send you updates on this idea

                          9 comments  ·  Flag idea as inappropriate…  ·  Admin →
                        • An error occurred while uploading the design (wrong me 69:-1:-1)

                          When the design specification is re-released, this error message appears when the progress bar reaches 99%. I am a paid user

                          8 votes
                          Sign in
                          Check!
                          (thinking…)
                          Reset
                          or sign in with
                          • facebook
                          • google
                            Password icon
                            Signed in as (Sign out)

                            We’ll send you updates on this idea

                            4 comments  ·  Flag idea as inappropriate…  ·  Admin →

                            Greetings:

                            Usually that error comes up when there’s a problem with the network. Have you had a chance to try publishing via a different network connection?

                            To help dig into things can you please share the following:
                            - XD version
                            - OS version
                            - Creative Cloud userID & country you’re publishing from
                            - Creative Cloud log files https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html

                            Thanks!
                            Nina
                            Adobe XD

                          • Error 22:-1:-1 when I want to publish my prototype

                            Everything is in the title. I canot publish a prototype. I have Error 22:-1:-1.

                            Thank you for your help

                            8 votes
                            Sign in
                            Check!
                            (thinking…)
                            Reset
                            or sign in with
                            • facebook
                            • google
                              Password icon
                              Signed in as (Sign out)

                              We’ll send you updates on this idea

                              9 comments  ·  Flag idea as inappropriate…  ·  Admin →

                              Hi David,
                              Sorry to hear you are running into trouble when trying to publish a prototype. An Error 22 indicates that XD was unable to generate bitmaps for the artboards in your design file.

                              Does your design file contain any particularly large artboards? If so, this is likely the source of the error. By reducing the size of your artboard, the publish operation should succeed.

                              If you can send your XD design file to AdobeXDSharingSupport@adobe.com – we can take a look and investigate further.

                              Alternatively, can you reply here with the dimensions of your largest artboard?

                              Are you able to publish from other XD design files with smaller artboards, or do you see this issue with all files?

                            • Type tool doesn't work well

                              The system fails to recognize new font's even after relaunch. Also, when typing the text is not visible and get's visibility back only after finishing with the element.

                              1. Adobe XD 9.1.12.3
                              2. Just type.
                              3. Text should be visible while typing.
                              4. Text is not Visible while typing.

                              7 votes
                              Sign in
                              Check!
                              (thinking…)
                              Reset
                              or sign in with
                              • facebook
                              • google
                                Password icon
                                Signed in as (Sign out)

                                We’ll send you updates on this idea

                                10 comments  ·  Flag idea as inappropriate…  ·  Admin →
                              • Font Awesome 5 intergration

                                I have just installed Font Awesome 5 (FA5) fonts for desktop. It doesn't show icons in XD (latest update to date), only text.
                                I type "tags", choose FA5 from font menu and it remains in text format - "tags", doesn't transform in tags icon, as it's supposed to do.

                                FA5 works in Illustrator and Photoshop.
                                I am also using Material Icons (MI), Google's ligature based icon font, and it works in XD. Font Awesome 4 (FA4) also works in XD (not ligature).

                                Any solution on this?
                                The reason I would love to switch to another ligature based icon font is…

                                7 votes
                                Sign in
                                Check!
                                (thinking…)
                                Reset
                                or sign in with
                                • facebook
                                • google
                                  Password icon
                                  Signed in as (Sign out)

                                  We’ll send you updates on this idea

                                  12 comments  ·  Flag idea as inappropriate…  ·  Admin →
                                • Prototyping and Copy & Paste

                                  The current version does not allow copy-Paste to preserve interaction wires/links
                                  Ability to copy wires along with assets. For example, if I have a home button that will always link to the same page, it would be helpful if I didn't have to wire the button each time. This would also be helpful when duplicating artboards so the links stay intact. For example, if I need to show a dropdown menu, I would do this by duplicating the artboard and adding a wire to the dropdown menu. In this case, I would want all the existing wires to stay the…

                                  6 votes
                                  Sign in
                                  Check!
                                  (thinking…)
                                  Reset
                                  or sign in with
                                  • facebook
                                  • google
                                    Password icon
                                    Signed in as (Sign out)

                                    We’ll send you updates on this idea

                                    3 comments  ·  Flag idea as inappropriate…  ·  Admin →
                                  • プロトタイプのコメント機能で、漢字変換を確定させるためのキー操作がコメントを投稿してしまう

                                    ウェブブラウザでプロトタイプを閲覧している時に使えるコメント機能に関するバグの報告です。

                                    再現方法
                                    1. コメント入力欄に日本語を入力する
                                    2. 漢字変換を確定させるためにキーボードのEnterキーを押す
                                    3. 変換の確定と同時にコメントが投稿されてしまう。

                                    私が期待していた動作
                                    1. コメント入力欄に日本語を入力する
                                    2. 漢字変換を確定させるためにキーボードのEnterキーを押す
                                    3. 漢字の変換が確定される
                                    4. 未確定の変換が残っていない状態でEnterキーを押すとコメントが投稿される

                                    すでに投稿されたコメントを編集するときも同様のことが起こります。
                                    コメント機能がとても使いづらくなっているので急いで直していただきたいです。

                                    この現象を確認した日
                                    2018/5/23
                                    (5月上旬の時点では「期待していた動作」の通り動いていました)

                                    環境
                                    Mac OSX 10.12.6
                                    Google Chrome 66.0.3359.181

                                    6 votes
                                    Sign in
                                    Check!
                                    (thinking…)
                                    Reset
                                    or sign in with
                                    • facebook
                                    • google
                                      Password icon
                                      Signed in as (Sign out)

                                      We’ll send you updates on this idea

                                      6 comments  ·  Flag idea as inappropriate…  ·  Admin →
                                    • Vector from CC Libraries loads blurry

                                      With the new update I've tried utilizing the new ability to use vectors in CC Libraries. However, when I drop them into my XD document, they never load fully and just show blurry with a refresh button over top.

                                      I've tried closing all of my adobe tools including the CC software manager as well as tried refreshing the images several times in XD.

                                      Currently on a Mac Mini.

                                      6 votes
                                      Sign in
                                      Check!
                                      (thinking…)
                                      Reset
                                      or sign in with
                                      • facebook
                                      • google
                                        Password icon
                                        Signed in as (Sign out)

                                        We’ll send you updates on this idea

                                        11 comments  ·  Flag idea as inappropriate…  ·  Admin →
                                      • error 1001 when click on publish

                                        I have done all attentions on my adobe profile also have done all steps in https://helpx.adobe.com/xd/kb/cannot-use-share-feature.html

                                        but still i cant publish my proto type or use Design Specs

                                        please help me and other users with the same issue. you are just addressing us to some useless approaches.

                                        6 votes
                                        Sign in
                                        Check!
                                        (thinking…)
                                        Reset
                                        or sign in with
                                        • facebook
                                        • google
                                          Password icon
                                          Signed in as (Sign out)

                                          We’ll send you updates on this idea

                                          6 comments  ·  Flag idea as inappropriate…  ·  Admin →

                                          Sorry to hear you are experiencing difficulty using the share online feature in XD. The error you are seeing indicates that there is a problem with the login state on your local machine.

                                          To resolve this issue, please first try the following:

                                          1. Close all Adobe applications
                                          2. Sign out of the Creative Cloud desktop application
                                          3. Restart the machine

                                          4. Login to the Creative Cloud desktop application

                                          5. Launch Adobe XD and attempt to use the share online functionality


                                          If the error persists after the actions above, the following steps should fix it:

                                          1. Close XD and all other Adobe applications
                                          2. Sign out and then quit the Creative Cloud desktop application
                                          3. Open the Activity Monitor (on macOS) or Task Manager (on Win10)
                                          4. Force quit/terminate the following processes:
                                          1. Adobe Desktop Service
                                          2. Core Sync
                                          3. Creative Cloud
                                          5. Navigate to the OOBE folder:
                                          1. Mac: Users/[user…

                                        • Wrong position of click area in browser

                                          The area for click not in right position. Then browser open in full screen the bug exist - then i decrease the size a bug disappear.

                                          5 votes
                                          Sign in
                                          Check!
                                          (thinking…)
                                          Reset
                                          or sign in with
                                          • facebook
                                          • google
                                            Password icon
                                            Signed in as (Sign out)

                                            We’ll send you updates on this idea

                                            bug-investigation-in-progress  ·  10 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                                          ← Previous 1 3 4 5 25 26
                                          • Don't see your idea?

                                          Adobe XD: Bugs

                                          Feedback and Knowledge Base