Adobe XD: Bugs

When filing a new bug, please provide:

  1. Version of Adobe XD
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. XD file, video or GIF capturing the issue (optional)

XD Known Issues list,
https://helpx.adobe.com/sea/xd/kb/known-issues.html#main-pars_text_2544517

Thank you.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Error (sometimes "Error 50" message) when trying to save XD file to Cloud Documents

    New XD update (December 2018) works great on my main machine (Windows 10 v1803). Though on my other machine with older Windows 10 (v1703 15063.447) I get this weird behavior. Maybe it is on Windows side, but I'd liked to report it just in case.

    15 votes
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)

      We’ll send you updates on this idea

      30 comments  ·  Flag idea as inappropriate…  ·  Admin →
    • 12 votes
      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)

        We’ll send you updates on this idea

        16 comments  ·  Flag idea as inappropriate…  ·  Admin →

        @Fernando Can you share the following logs:
        -XD log: c:\Users\USERNAME\AppData\Local\Packages\Adobe.CC.XD_adky2gkssdxte\LocalState\AdobeXD.log
        - Creative Cloud logs https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html

        @Ahsan: Is it possible you installed other Adobe apps to that directory? Can you check what install is set to? To check, check in Creative Cloud desktop app>Preferences>Creative Cloud>Apps

      • Undo (cmd + z) stops working

        I have discovered that the undo function (cmd + z) stops working in XD after I have worked on a document for a while. Things that I typically undo is positioning of elements. Undo starts working again if you quit and reopen XD.

        This has happened a few times the last week.

        Environment details:
        - macOS High Sierra Version 10.13.6
        - Adobe XD version 11.0.22.10

        34 votes
        Sign in
        Check!
        (thinking…)
        Reset
        or sign in with
        • facebook
        • google
          Password icon
          Signed in as (Sign out)

          We’ll send you updates on this idea

          28 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
        • Can not export After Effect files

          Version of Adobe XD: 13.0.12.14
          Steps to reproduce the issues: files > export > After Effect
          Expected result: export AE file successfully
          Actual result: display "There was a problem exporting your asset."

          Please help me~ thanks

          6 votes
          Sign in
          Check!
          (thinking…)
          Reset
          or sign in with
          • facebook
          • google
            Password icon
            Signed in as (Sign out)

            We’ll send you updates on this idea

            14 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
          • [Win 10] Incorrect display when re-ordering layers

            windows 10
            GTX 1080 (latest drivers 399.07).

            Reordering layers (not only groups) randomly (i'd say 1 every 10 reordering wihtout noticable pattern) leaves a persistent ghost of the dragged item (even outside the application, ie on the desktop) and reordering stops working after that.

            Ghost is often presented as a slashed red circle within a grey square, in the case of dragging a single layer (screenshot attached)

            This bug has been present since this feature was introduced in XD.
            Every session of my work in xd is plagued with this issue.

            18 votes
            Sign in
            Check!
            (thinking…)
            Reset
            or sign in with
            • facebook
            • google
              Password icon
              Signed in as (Sign out)

              We’ll send you updates on this idea

              11 comments  ·  System  ·  Flag idea as inappropriate…  ·  Admin →

              Thanks for the additional information. There seem to be a number of issues you’re seeing.

              For layers re-order, there were some improvements incorporated into XD a few builds ago. But sounds like that may not be helping in your case.

              The biggest culprit for Win10 performance issues in XD is video card incompatibility. For this, verifying that you 1) your card is supported in the Win10 OS you’re working with & 2) you have the latest driver, will address a significant number of issues.

              To better understand what’s going, having the following helps to narrow things down:
              - XD version
              - OS version
              - video card model & driver version
              - Is the problem observed in all files? Or just some
              - How do other UWP apps behave?

              Thanks!
              Nina

            • Cloud Documents "Something Went Wrong"

              I'm on the latest version of Adobe XD - 14.0.42.14 (Dec 2018 update).

              SEE ATTACHED VIDEO:

              In the home screen, I can't click on any device icons so I can start a new document.

              When I click on the Cloud Documents tab on the sidebar, I get the error prompt message 'Something Went Wrong, please restart the App"

              I restart the app and it's still the same thing.

              I've done a clean, hard, reinstall (removed existing app preferences), but still nothing.

              I've found though that I can open up existing XD files. Once opened, I can't save any of them…

              4 votes
              Sign in
              Check!
              (thinking…)
              Reset
              or sign in with
              • facebook
              • google
                Password icon
                Signed in as (Sign out)

                We’ll send you updates on this idea

                7 comments  ·  System  ·  Flag idea as inappropriate…  ·  Admin →

                @Tim @William
                Can you try the following to kick off Adobe Sync update?
                1. Exit from all Adobe Applications (including Adobe Creative Cloud itself).
                2. From the Windows Task Manager, force-end all Adobe related services
                3. On Win:
                Go to “C:\Program Files (x86)\Adobe”, rename the “Adobe Sync” folder to “Adobe Sync-OLD
                On Mac:
                Go to: :~/Users//Library/Application Support/Adobe/CoreSync" rename “CoreSync” to “CoreSync-OLD
                4. Launch Adobe Creative Cloud application and allow update process to happen

              • Wrong position of click area in browser

                The area for click not in right position. Then browser open in full screen the bug exist - then i decrease the size a bug disappear.

                5 votes
                Sign in
                Check!
                (thinking…)
                Reset
                or sign in with
                • facebook
                • google
                  Password icon
                  Signed in as (Sign out)

                  We’ll send you updates on this idea

                  bug-investigation-in-progress  ·  10 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                • Repeat grid is now including shadow in the spacing value

                  When an element has a shadow and a repeat grid is applied the spacing option now includes the shadow width or height as part of that padding.

                  version: 14.0.42.14

                  4 votes
                  Sign in
                  Check!
                  (thinking…)
                  Reset
                  or sign in with
                  • facebook
                  • google
                    Password icon
                    Signed in as (Sign out)

                    We’ll send you updates on this idea

                    5 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
                  • Prototype blurry and squished

                    Prototypes are sometimes squished horizontally, blurry, or only show half the layout! It happens randomly, has nothing to do with monitors or browsers...done lots of testing in the office on different machines.

                    I have to send layouts to client today! Will have to send JPGs instead, very disappointed with the application.

                    My XD version is up-to-date XD CC, using a MAC.

                    Any help would be appreciated. If we cannot use the prototype feature XD is useless.

                    5 votes
                    Sign in
                    Check!
                    (thinking…)
                    Reset
                    or sign in with
                    • facebook
                    • google
                      Password icon
                      Signed in as (Sign out)

                      We’ll send you updates on this idea

                      7 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                    • Unable to share for development

                      Adobe XD version 14.0.42.14

                      When trying to share for development, the progress doesn't move forward and the spinning wheel gets stuck at 0%, getting unable to update / create the link

                      2 votes
                      Sign in
                      Check!
                      (thinking…)
                      Reset
                      or sign in with
                      • facebook
                      • google
                        Password icon
                        Signed in as (Sign out)

                        We’ll send you updates on this idea

                        6 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                      • Wrong font weight on iOS device preview

                        When I preview my designs on my iPhone X, it always shows a very thin font weight. This makes it very difficult to design with Adobe XD. When I preview on the computer, it displays correctly but this isn't nearly as helpful to look at. The font I'm using is a Google font called IBM Plex Sans. I have confirmed it's displaying the correct font but the weight is wrong. Please help!

                        2 votes
                        Sign in
                        Check!
                        (thinking…)
                        Reset
                        or sign in with
                        • facebook
                        • google
                          Password icon
                          Signed in as (Sign out)

                          We’ll send you updates on this idea

                          bug-investigation-in-progress  ·  6 comments  ·  Flag idea as inappropriate…  ·  Admin →
                        • Prototype not working Artboards not linking

                          Using XD version: 14.0.42.14 and the prototypes are not working (again!).

                          The initial page is previewing, but the links to other artboards are not functioning (on all browsers, Mac and PC). The hotspot hints show, but don't link as intended.

                          Need to send to client today! help please.

                          2 votes
                          Sign in
                          Check!
                          (thinking…)
                          Reset
                          or sign in with
                          • facebook
                          • google
                            Password icon
                            Signed in as (Sign out)

                            We’ll send you updates on this idea

                            5 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                          • Sharing error (44:77:0)

                            1. 4.0.12.6 (adobe xd), 2.4.4.71 (cloud sync version)
                            2. Have a prototype (with single or multiple artboards connected), share the prototype as specs or normal prototype.
                            3. Sharing should be succesfull.
                            4. Error 44:77:0 is shown.

                            Tried multiple times, with smaller and bigger artboards. The error is always the same.

                            34 votes
                            Sign in
                            Check!
                            (thinking…)
                            Reset
                            or sign in with
                            • facebook
                            • google
                              Password icon
                              Signed in as (Sign out)

                              We’ll send you updates on this idea

                              47 comments  ·  Flag idea as inappropriate…  ·  Admin →
                            • Open Shared Cloud file Error.

                              Hi There,

                              When I was working on the same file my friend shared, after some hours XD shows below message.
                              (Attach : Desktop screenshot.png)

                              Whenever I'm Opening the file it shows below message.
                              (Attach : Desktop screenshot 1.png)

                              can you someone tell me what the issue this.

                              Thanks,
                              Mukund

                              3 votes
                              Sign in
                              Check!
                              (thinking…)
                              Reset
                              or sign in with
                              • facebook
                              • google
                                Password icon
                                Signed in as (Sign out)

                                We’ll send you updates on this idea

                                2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                              • Overlays appear blurry/low resolution in preview mode

                                Adobe XD v12.0.12.10 on Mac (I can't update yet because of my OC version)

                                Overlays appear blurry/low resolution in preview mode.

                                Seems like the prototype preview isn't rendering overlays properly, making them look blurry compared to the elements in the base artboard.

                                Attached screenshot shows an overlay (hover effect) on the left and the base artboard on the right. Naturally we need the overlay to be as crisp & clear as the rest of the interface.

                                2 votes
                                Sign in
                                Check!
                                (thinking…)
                                Reset
                                or sign in with
                                • facebook
                                • google
                                  Password icon
                                  Signed in as (Sign out)

                                  We’ll send you updates on this idea

                                  bug-investigation-in-progress  ·  4 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                                • XD Prototype tiny in browser(s)

                                  Just updated XD today (13.1.32.8) , now all prototypes (on Safari and Chrome) are showing a tiny thumbails.....is this ever going to work properly? This is the 4th issue in 1 week. crazy. Prototypes are so unreliable, it's impossible to share with clients....

                                  2 votes
                                  Sign in
                                  Check!
                                  (thinking…)
                                  Reset
                                  or sign in with
                                  • facebook
                                  • google
                                    Password icon
                                    Signed in as (Sign out)

                                    We’ll send you updates on this idea

                                    4 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                                  • XD 14.0.42.14 - again problem with polish special letters - this time with "ć" and "ł"

                                    1. Adobe XD 14.0.42.14
                                    2. Again after the newest (December 2018) update, there is a problem with 2 polish special letter during typing into text frame: "ć" (AltGr + "c") and "ł" (AltGr + "l".
                                    3. Expecting to write "ć" and "ł"
                                    4. Nothing happens after trying to type those letters.

                                    Adobe! ;) ;) ;) - please ;););) again????? ;););)

                                    Thanks!!!!!

                                    1 vote
                                    Sign in
                                    Check!
                                    (thinking…)
                                    Reset
                                    or sign in with
                                    • facebook
                                    • google
                                      Password icon
                                      Signed in as (Sign out)

                                      We’ll send you updates on this idea

                                      3 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
                                    • XD not starting after laptop shut down due to low battery

                                      I was working on a XD file when my computer shut down due to running too low on battery. I had the file saved just before this happens. However, having the laptop (Surface Pro) plugged in now, XD would not start correctly. It would remain on the start screen where I should be able to select from the recent files but i cannot click on any tile and the window closes entirely shortly after. Same happens if I try to open XD from the Creative Cloud pannel. When I double click on the xd file I have saved on my…

                                      1 vote
                                      Sign in
                                      Check!
                                      (thinking…)
                                      Reset
                                      or sign in with
                                      • facebook
                                      • google
                                        Password icon
                                        Signed in as (Sign out)

                                        We’ll send you updates on this idea

                                        3 comments  ·  System  ·  Flag idea as inappropriate…  ·  Admin →

                                        Hiya Elisabeth (just noticed I spelled your name incorrectly previously – apologies!) Really appreciate the additional investigation on your part.

                                        For updating drivers, here’s some info:
                                        https://support.microsoft.com/en-us/help/4023482/surface-download-drivers-and-firmware-for-surface

                                        Depending on which graphic card you have, it would be good to check the manufacturer for newer drivers as the MS site may not have the latest. You can check in Device Manager, https://www.techwalla.com/articles/how-to-test-a-cpu

                                        For the file, unfortunately the file cannot be recovered from the published prototype, this is a separate file type. However, if the file was saved to Creative Cloud files, there should be a copy available.

                                        I’m looking at the error log and see the file was saved in drive G:\ – were you collaborating with someone else on this design? I have seen where sometimes more than one user makes edits to the file on a shared location can result in this scenario.

                                        With this message “Unable to open…

                                      • Auto-Animate breaks when changing non relevant object

                                        1: 13.1.32
                                        2:
                                        a) Creating an auto animation between the same object (text field) on another artboard.
                                        b) Everything works fine, the exact text field moves to the spot where i changed it to.
                                        c) As soon is a change the hierachy of a completely different object on this artboard, it looses its connection and "moves" another text field instead of the previous one.

                                        3. One text field to move from one place to another within the transition
                                        4. The Text field seems to "fly in" from another spot in the artboard.
                                        5. Please excuse the sloppy mouse movement. The…

                                        0 votes
                                        Sign in
                                        Check!
                                        (thinking…)
                                        Reset
                                        or sign in with
                                        • facebook
                                        • google
                                          Password icon
                                          Signed in as (Sign out)

                                          We’ll send you updates on this idea

                                          bug-investigation-in-progress  ·  4 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                                        • Firefox: links in broswer view are shifted when artboard is to long.

                                          Version of Adobe XD: 13.1.32.8

                                          Steps to reproduce the issues:
                                          - Create two artboards
                                          - Make the first artboard at least 5000px tall and add an element to it
                                          - Link the entire artboard to the other artboard
                                          - Save, then publish a prototype
                                          - Open the link in Firefox
                                          - Hover around the first artboard and you will find that the right side and bottom of the artboard is not linked (no pointer cursor).

                                          If the artboard is around 3400px tall or shorter the link does not shift. It seems that as soon as the artboard goes taller than…

                                          3 votes
                                          Sign in
                                          Check!
                                          (thinking…)
                                          Reset
                                          or sign in with
                                          • facebook
                                          • google
                                            Password icon
                                            Signed in as (Sign out)

                                            We’ll send you updates on this idea

                                            2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →

                                            Greetings Colin:

                                            Thanks for the detailed steps + XD file!

                                            I did some looking and here’s what I found. On the prototype you share, I am able to reproduce the problem you state. When opening the file in XD, I noticed that you had vertical scrolling enabled on both artboards. On the home artboard viewport was set to the height of the artboard (5000). I changed that to be 1080 and now when looking at the published prototype the bottom right shows that it has a link to another artboard. However, I do notice that along the right edge there’s a buffer where it doesn’t trigger the hand pointing cursor. https://xd.adobe.com/view/48fba056-d3c5-41bd-622d-907681ca931a-3eca/ (added a shape at the bottom right for visual reference).

                                            Looking into it more but hope the above helps in case you’re working with taller than 3400px artboards.

                                            Thanks!
                                            Nina
                                            Adobe XD

                                          ← Previous 1 3 4
                                          • Don't see your idea?

                                          Adobe XD: Bugs

                                          Feedback and Knowledge Base