Adobe XD: Bugs

When filing a new bug, please provide:

  1. Version of Adobe XD
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. XD file, video or GIF capturing the issue (optional)

XD Known Issues list,
https://helpx.adobe.com/sea/xd/kb/known-issues.html#main-pars_text_2544517

Thank you.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Component cropping

    Making a path into a component crops the rounded caps off

    69 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  30 comments  ·  Flag idea as inappropriate…  ·  Admin →
  2. 40 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Flag idea as inappropriate…  ·  Admin →
  3. pdf export blurry images (with shadow) and file size

    When exporting to pdf, the file size becomes quite huge.
    Additionally, the images that have a shadow (added in XD, image is jpeg) become blurry and the text (in the image) unreadable. It's no problem without shadow.

    24 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Flag idea as inappropriate…  ·  Admin →
  4. ANNOYING BUG: Prototype wires not showing when selecting artboards

    The wires on objects on artboards do not show when selecting the artboard.

    You have to select the object itself.

    I prefer if I do not have to deep-select to see all the connections set up on an artboard.

    I want it to be like it was initially; selecting and artboard shows all prototype wires.

    17 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    15 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  5. cannot read property 'postscriptName' or null

    It tells me "cannot read property 'postscriptName' or null" and then showing just a blank page. Reboot, re-install, older version doesn't work.

    Win10/64,

    XD - 8.022.11

    11 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  8 comments  ·  Flag idea as inappropriate…  ·  Admin →
  6. Color issues

    Hexcodes appear very different between art boards. Looks like it gets an opacity change without it actually being changed. The opacity slider says its 100% but the color obviously isn't showing opaque.

    Colors suddenly changes opacity from 100% and when its closed and then opened the opacity has changed.


    The checkbox next to the color square in the front UI is sometimes totally black and sometimes its not possible to click in the box to turn a border color or fill color on, this has been an ongoing issues since day one with XD.

    Also, the color picker keeps disappearing.…

    10 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  9 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  7. CC Library doesn't show Transparency

    Hello there,

    I'm not sure if this has changed since the update, but on Mac ver 14.0.42.14 the CC library does not show Transparency in the preview. This means its hard to tell which Icon I'm trying to place:

    See here:

    Bridge is on the left (see there is Trans) XD is on the Right

    10 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Flag idea as inappropriate…  ·  Admin →
  8. Color change animation

    Hello guys, I really don't know if this is a real bug but I should report, when auto animation, the object color don't make the transition steps, the color change suddenly, is that a real bug?

    8 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  9. Text changed using new features does not convert in developer mode

    See screen grab. Text was highlighted and changed from caps to sentence case using new casing feature. When shared for development text still showing as capitals to copy and paste.

    8 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  Share for Development  ·  Flag idea as inappropriate…  ·  Admin →
  10. プロトタイプのコメント機能で、漢字変換を確定させるためのキー操作がコメントを投稿してしまう

    ウェブブラウザでプロトタイプを閲覧している時に使えるコメント機能に関するバグの報告です。

    再現方法
    1. コメント入力欄に日本語を入力する
    2. 漢字変換を確定させるためにキーボードのEnterキーを押す
    3. 変換の確定と同時にコメントが投稿されてしまう。

    私が期待していた動作
    1. コメント入力欄に日本語を入力する
    2. 漢字変換を確定させるためにキーボードのEnterキーを押す
    3. 漢字の変換が確定される
    4. 未確定の変換が残っていない状態でEnterキーを押すとコメントが投稿される

    すでに投稿されたコメントを編集するときも同様のことが起こります。
    コメント機能がとても使いづらくなっているので急いで直していただきたいです。

    この現象を確認した日
    2018/5/23
    (5月上旬の時点では「期待していた動作」の通り動いていました)

    環境
    Mac OSX 10.12.6
    Google Chrome 66.0.3359.181

    6 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Flag idea as inappropriate…  ·  Admin →
  11. You can try accessing the link again or, if the error persists

    Hi

    I'm facing this issues in many prototype links. Can u please check and let me know the solution plz.

    Thanks
    Kasi

    5 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  3 comments  ·  Share for Review  ·  Flag idea as inappropriate…  ·  Admin →
  12. Duplicated elements inside non-master components despite master reset...

    Title says everything, I have no way to reproduce this...

    I have a master document with all my master components, one of them has a nested component, everything is working fine with the others, even when they have nested components BUT this one.

    What's happening is that in a project file (not the master one), all it's instances have a duplicate of the nested component, even after a reset, even after deleting the component from the library...

    Any ideas?

    5 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  4 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  13. Pasting clipboard shapes while editing the artboard name freezes the software

    If I copy shapes to the clipboard and accidentally paste it while editing the artboard name the software almost crashes, takes around 3-5 mins to come back and paste the SVG code of the shapes I did copy before.
    I wish you guys could block the ability to paste the shapes SVG codes while editing the artboard name.
    This silly mistake has been happening a lot to me, renaming artboards properly is something crucial for my work and I'm used to copying and pasting other artboard names and edit just a part of it. But it happens that between renaming…

    4 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  4 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  14. Character styles are not tagging correctly. Changing in unexpected locations in file

    I have four character styles that I am using in my file. The text is styled the way I want, but when I paste additional copy...text that is not even close to the pasted text changes style. I have before and after pictures attached to show. This has happened several times. I am on the Windows platform. Also note that the pasted text changes styles i the middle.

    4 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  7 comments  ·  Flag idea as inappropriate…  ·  Admin →
  15. Dragging elements off artboard become hidden (intermittently)

    Weird issue I noticed happening the other day, and again just now. Some elements stay linked to the artboard they previously occupied even after I've dragged them off. I don't always notice this has happened, until I select an artboard and notice elements surrounding it suddenly appear, then disappear when the artboard is deselected.

    1. Version 15.0.12.8

    2. Select an element and drag it off an artboard.

    3. I expect the element to stay visible; I expect the element to stay visible even though it is not attached to an artboard.

    4. Sometimes the selected/dragged element immediately becomes hidden, even…

    4 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  6 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  16. Repeat grid missing after export to jpg

    I discovered that some of my repeat grids are missing after exporting to jpg.

    For example, I have very long page for some project (25000px height) and there are multiple repeat grids on same page. I made first one and copied whole repeat grids 3 times. After I export my design as jpg, the 1st and 2nd one are there, but 3rd one is missing after export. I tried to move my 3rd repeat grid up, just bellow 2nd one and then it's there, but that's not option for me, I need this repeat grid at the end of the…

    3 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  17. Crash trying to rename a layer by double-click

    Adobe XD 16.0.2.8, Windows 10,

    Renaming of any layer by double-click leads to crash (seldom).

    I cannot reproduce it easily by many double-clicks, but 2 per an hour Adobe XD crashes on my attempt to rename some layer by double-click.

    3 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  6 comments  ·  Flag idea as inappropriate…  ·  Admin →
  18. Adobe Illustratorからコピペすると、フォント情報が正しく引き継げない

    # 再現方法

    1. Illustratorで「ABCD」とテキストをうち「游ゴシック体 Bold」を指定
    2. XDで新規ファイルを作成
    3. 1のテキストをコピーして2にペースト
    4. [発生] 貼り付けたテキストが「游ゴシック体 bold」(※Bが小文字)になっており、フォントの表示が正しくない。
    5. 4のXDファイルを名前をつけて保存し、閉じて、開く
    6. [発生] 「1個のフォントが見つかりません。環境にないフォントを表示」というエラーメッセージが出て、「• YuGothic-bold」が無いと言われる。

    # 問題点

    Illustratorからコピペした場合にきちんとフォント情報が正しく引き継げていません。
    その他の日本語フォントでも起こります。
    エラー部分で表示されるフォント名もUIの表記と合わせて日本語にするべきではないでしょうか?

    # 環境

    XD 15.0.12.8
    Illustrator 23.0.1

    3 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  System  ·  Flag idea as inappropriate…  ·  Admin →
  19. shared prototypes not visible

    Please refer to the attached video.

    one of the stakeholders reported she couldn't see the new prototype at assets.adobe.com. I shared it with her. We found out, they appear when toggling to the listview and back, or when resizing the browser window.

    After a browser refresh, the same behaviour occurs. Only one prototype is visible, the others appear after resize or toggle list / grid view.

    Is this a known issue?

    3 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
  20. Gradient direction is different when saved into assets panel

    When I'm trying to use a gradient from my assets it works, but not in the direction I saved it in.

    1. Created gradient on shape
    2. Added gradient to assets (the preview in the assets shows how I saved it, in the correct way)
    3. Applying this gradient works, but the direction is from top to bottom instead of left to right.

    Feel free to ask for more information! Added a image, right button is how it is applyed while it should apply like the left button.

    3 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5
  • Don't see your idea?

Feedback and Knowledge Base