Adobe XD: Bugs

When filing a new bug, please provide:

  1. Version of Adobe XD
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. XD file, video or GIF capturing the issue (optional)

XD Known Issues list,
https://helpx.adobe.com/sea/xd/kb/known-issues.html#main-pars_text_2544517

Thank you.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Typing the letter "J" at the beginning of a "point textbox" causes the textbox to move left 1-2 points depending on font size

    Version 12.0.12.10
    Creative Cloud Sync 4.0.0.46
    Windows 10 Pro N - Version 1703
    Desktop i7-4770 - 32 GB

    Whenever I type the letter "J" at the beginning of a left-aligned "point textbox", the textbox will move left 1-2 points depending on the font size. Also, when I use an "area texbox" the J visually sticks out of the text box boundary. This doesn't appear to happen with any other letter.

    Upon further review, it seems that this is only happening with the font "Open Sans". It also seems that setting other fonts to italics (doesn't matter which font), the text…

    1 vote
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)

      We’ll send you updates on this idea

      0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
    • 1 vote
      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)

        We’ll send you updates on this idea

        0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
      • Design specs sync

        Hi! I have about 50 screens in my file and both design specs and prototyping have worked perfectly. But last week when I was updating the links only 6 artboards appeared in design specs and prototype. I have tried to make new links, copying the artboards into a new file and linking everything from scratch – but nothing works. No, I can see 25 artboards - so there is progress but about half of the artboards are still missing. I have the newest version of Adobe XD. The project is confidential so unfortunately I can't share the file with you…

        1 vote
        Sign in
        Check!
        (thinking…)
        Reset
        or sign in with
        • facebook
        • google
          Password icon
          Signed in as (Sign out)

          We’ll send you updates on this idea

          1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →

          Greetings Amalie:

          Sorry to hear things aren’t working well for you.

          A few things that might help you troubleshoot what’s going on,
          Troubleshooting guide for common Design Spec publish issues: https://helpx.adobe.com/xd/kb/design-spec-errors-workarounds.html
          Checking the services status page for any updates or issues, status.adobe.com (Creative Cloud)

          Sometimes restating the system or publishing from a different network can “fix” things.

          Hope this helps!
          Nina
          Adobe XD

        • Design Specs

          I am trying to update design specs of my project, and appears the message "There was a problem creating your design spec.

          Troubleshoot publish errors"

          1 vote
          Sign in
          Check!
          (thinking…)
          Reset
          or sign in with
          • facebook
          • google
            Password icon
            Signed in as (Sign out)

            We’ll send you updates on this idea

            0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
          • Artboards that are NO longer in the designfile, are still showing as artboards in the iOS app.

            Artboards that are NO longer in the designfile, are still showing as artboards in the iOS app? They have been deleted in the file in CC, opened on mobile and they are still there? It is not only iPad artboards, it's like old artboards and iterations showing up. The file is 100% up to date.

            1 vote
            Sign in
            Check!
            (thinking…)
            Reset
            or sign in with
            • facebook
            • google
              Password icon
              Signed in as (Sign out)

              We’ll send you updates on this idea

              0 comments  ·  Flag idea as inappropriate…  ·  Admin →
            • September update cannot export PDF, PNG on Mac OS

              September 2018 update has broken this feature. All exported files have 0k filesize.

              1 vote
              Sign in
              Check!
              (thinking…)
              Reset
              or sign in with
              • facebook
              • google
                Password icon
                Signed in as (Sign out)

                We’ll send you updates on this idea

                0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →

                Greetings Andrew:

                Can you provide further details? Do see this problem in all files? What about in a project with a single shape or artboard?

                I’m working with XD 12 on MacOS 10.12.6 and export of PDF + PNG (and JPG, SVG) is working without issues.

                Are you able to share your file via WeTransfer.com?

                Thanks!
                Nina
                Adobe XD

              • Cant Create a New Deisgn Spec

                1. Adobe XD Version 11.0.22.10

                2. On an existing cloud saved project, go to "Publish Design Specs", include assets, and hit "New Link"

                3. I would expect a new design spec to upload and be published, that I can then share.

                4. It uploads all the way to 100% and then tells me it could not update my design spec (even though I'm creating a new one, and I've also deleted the old spec) and gives me the error 44:47:0. After this, if I try publishing a new link again, it tells me that "There was a problem creating our…

                1 vote
                Sign in
                Check!
                (thinking…)
                Reset
                or sign in with
                • facebook
                • google
                  Password icon
                  Signed in as (Sign out)

                  We’ll send you updates on this idea

                  1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                • copy&paste from XD to other apps

                  It's impossible to copy smth from XD and paste it to Outlook letter for example (or another app) as picture. Then I do it I see just black rectange. Look at the attachment.

                  1 vote
                  Sign in
                  Check!
                  (thinking…)
                  Reset
                  or sign in with
                  • facebook
                  • google
                    Password icon
                    Signed in as (Sign out)

                    We’ll send you updates on this idea

                    1 comment  ·  Flag idea as inappropriate…  ·  Admin →

                    Oh I see. You may be working with files the pasteboard in Win is saving in a way that Outlook can’t understand. I recommend exporting to PNG or JPG file from XD for accurate representation.

                    The cases for asset import/export/copy/paste the team has validated are defined here, https://helpx.adobe.com/xd/help/working-with-external-assets.html For other support not included, I encourage you to open a feature request for the team to review.

                    Hope this helps!
                    Nina

                  • Text

                    When we drag a vector illustration for Illustrator to XD, everything work fine. But text written on curved path in AI is displayed as written horizontally in XD. Please check this
                    issue.

                    1 vote
                    Sign in
                    Check!
                    (thinking…)
                    Reset
                    or sign in with
                    • facebook
                    • google
                      Password icon
                      Signed in as (Sign out)

                      We’ll send you updates on this idea

                      0 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
                    • Image blurry when viewed on mobile

                      Hi,

                      Not sure if it is me, I am using a rather large image as my home page background on the app. It is a high quality image and appears fine on the PC.

                      However when I view on mobile it looks very grainy.

                      Any idea how I can rectify?

                      Thanks

                      Nathan

                      1 vote
                      Sign in
                      Check!
                      (thinking…)
                      Reset
                      or sign in with
                      • facebook
                      • google
                        Password icon
                        Signed in as (Sign out)

                        We’ll send you updates on this idea

                        1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                      • WebGL error when trying to view online

                        I cannot view Prototypes on the web in our main conference room through Chrome. I checked and it is fully updated. I don't have this issue on any other system and I have tried multiple different XD projects. Other browsers can preview them fine.

                        bundle-4c5f7f1a21d44ccbb21c.js:130 TypeError: Cannot read property 'disable' of undefined
                        at glDisable (2-8ea5eb90decc8fa9c3ba.js:1)
                        at Lb (2-8ea5eb90decc8fa9c3ba.js:1)
                        at ac (2-8ea5eb90decc8fa9c3ba.js:1)
                        at Hs (2-8ea5eb90decc8fa9c3ba.js:1)
                        at OS (2-8ea5eb90decc8fa9c3ba.js:1)
                        at bn (2-8ea5eb90decc8fa9c3ba.js:1)
                        at (2-8ea5eb90decc8fa9c3ba.js:1)
                        at Nr.initialize (2-8ea5eb90decc8fa9c3ba.js:1)
                        at Object.t.initializePlayer (bundle-4c5f7f1a21d44ccbb21c.js:37)
                        at t.value (bundle-4c5f7f1a21d44ccbb21c.js:185)
                        at e.notifyAll (bundle-4c5f7f1a21d44ccbb21c.js:130)
                        at d.close (bundle-4c5f7f1a21d44ccbb21c.js:145)
                        at d.closeAll (bundle-4c5f7f1a21d44ccbb21c.js:37)
                        at d.perform (bundle-4c5f7f1a21d44ccbb21c.js:37)
                        at x.perform (bundle-4c5f7f1a21d44ccbb21c.js:37)
                        at x.perform (bundle-4c5f7f1a21d44ccbb21c.js:23)
                        fn…

                        1 vote
                        Sign in
                        Check!
                        (thinking…)
                        Reset
                        or sign in with
                        • facebook
                        • google
                          Password icon
                          Signed in as (Sign out)

                          We’ll send you updates on this idea

                          0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                        • 不能从外部图片拖入到XD,显示禁止的标识;Can not be dragged from external images to XD to display prohibited signs.

                          WIN 10版本Adobe XD CC,我尝试拖动jpg,png图片进去出现禁止的符号;甚至连PS和AI里面也拖动进去也是禁止;也尝试Creative Cloud同步,提示我不具备管理权限;

                          操作系统:win10(17134)
                          XD CC版本:11.0.22.10

                          WIN 10 version of Adobe XD CC, I tried to drag jpg, png picture into the forbidden symbol; even the PS and AI inside is also prohibited to drag in; also try Creative Cloud synchronization, suggesting that I do not have administrative privileges;

                          1 vote
                          Sign in
                          Check!
                          (thinking…)
                          Reset
                          or sign in with
                          • facebook
                          • google
                            Password icon
                            Signed in as (Sign out)

                            We’ll send you updates on this idea

                            2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
                          • Sign in request

                            XD constantly requests signing in? Is there a good reason for this? If I'm already signed in to CreativeCloud this is irritating. I wouldn't want to sign in to every creative cloud app individually so why would is this happening?

                            1 vote
                            Sign in
                            Check!
                            (thinking…)
                            Reset
                            or sign in with
                            • facebook
                            • google
                              Password icon
                              Signed in as (Sign out)

                              We’ll send you updates on this idea

                              0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
                            • Chrome [Violation] Parser was blocked due to document.write...

                              I'm getting a parsing error in Chrome preventing my screen to completely load properly.

                              Chrome Version 68.0.3440.106 (Official Build) (64-bit)

                              Note: Works well in Safari

                              [Violation] Avoid using document.write().
                              U @ main.min.js:1
                              (anonymous) @ main.min.js:1
                              (anonymous) @ main.min.js:1
                              main.min.js:1 [Violation] Parser was blocked due to document.write(<script>)
                              U @ main.min.js:1
                              (anonymous) @ main.min.js:1
                              (anonymous) @ main.min.js:1
                              main.min.js:1 A parser-blocking, cross site (i.e. different eTLD+1) script, https://c.evidon.com/geo/country.js, is invoked via document.write. The network request for this script MAY be blocked by the browser in this or a future page load due to poor network connectivity. If blocked in this page load,…

                              1 vote
                              Sign in
                              Check!
                              (thinking…)
                              Reset
                              or sign in with
                              • facebook
                              • google
                                Password icon
                                Signed in as (Sign out)

                                We’ll send you updates on this idea

                                1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
                              • Transparency Bug

                                Greeting! Im using XD on a macbook pro 15' mid 2014.

                                Everytime I open my XD project, some shapes get 80% transparency out of nowhere.

                                So everytime I work on this project, the first thing I have to do is check all
                                shapes on the file... Its taking too much of my time. Im even leaving the file open so I don't have to do it again and again.

                                Please Fix!
                                tks!

                                1 vote
                                Sign in
                                Check!
                                (thinking…)
                                Reset
                                or sign in with
                                • facebook
                                • google
                                  Password icon
                                  Signed in as (Sign out)

                                  We’ll send you updates on this idea

                                  0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
                                • Font size with keyboard works up but not down

                                  When marking the text, klikking on the font size adjuster and using the arrows up to increase the font size works but not when I want to press the down arrow to make it smaller. I vaguely remember this working earlier but I might be wrong.

                                  Same is true for most things where you can adjust the size with numbers. Line hight and the size of recrangle and elipses as well.

                                  I'm using MacOS High Sierra

                                  1 vote
                                  Sign in
                                  Check!
                                  (thinking…)
                                  Reset
                                  or sign in with
                                  • facebook
                                  • google
                                    Password icon
                                    Signed in as (Sign out)

                                    We’ll send you updates on this idea

                                    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
                                  • Artboard Title Text overwrites

                                    As previously described, however that report has been closed, so I need to open a new report here.

                                    Place an artboard to the extreme right hand side of the work area and then see if you can edit the name. The edits overwite the old name and scramble the display. The name still displays correctly in the layers pallet.

                                    I don't have the problem with artboard name edits in the left part of the screen/work area!

                                    This does need some attention.

                                    1 vote
                                    Sign in
                                    Check!
                                    (thinking…)
                                    Reset
                                    or sign in with
                                    • facebook
                                    • google
                                      Password icon
                                      Signed in as (Sign out)

                                      We’ll send you updates on this idea

                                      3 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
                                    • Clicking more then three times on a grouped object causes artboards to freeze, saving then enables the artboards again.

                                      Clicking more than three times on a grouped object causes artboards to freeze, saving then enables the artboards again.

                                      1 vote
                                      Sign in
                                      Check!
                                      (thinking…)
                                      Reset
                                      or sign in with
                                      • facebook
                                      • google
                                        Password icon
                                        Signed in as (Sign out)

                                        We’ll send you updates on this idea

                                        0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →

                                        Greetings:

                                        Wondering if this might be a symptom of https://adobexd.uservoice.com/forums/353010-adobe-xd-bugs/suggestions/34689346 where users find the app stops responding but changing focus away and back resolves. I do note you make a different observation in that saving the file action recovers.

                                        Not something we’ve specifically observed on our end. Do you see this every time you click 3x into every grouped object? Or is it occasional. Can you try instead of saving changing focus away and back to XD to see if that fixes it as well?

                                        Thanks!
                                        Nina
                                        Adobe XD

                                      • Mobile Preview doesn't work with new Android

                                        When I plug in the usb, live preview just keeps spinning without loading the preview. It used to work before the Android update.

                                        Google Pixel 2 phone. Android 9. Mac OSX 10.12.6

                                        1 vote
                                        Sign in
                                        Check!
                                        (thinking…)
                                        Reset
                                        or sign in with
                                        • facebook
                                        • google
                                          Password icon
                                          Signed in as (Sign out)

                                          We’ll send you updates on this idea

                                          0 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
                                        • Issues with large artboard

                                          Version of Adobe XD: 11.0.22.10
                                          System: Windows 10 (updated), GeForce GTX 750 Ti (drivers updated)

                                          Issue 1:
                                          When a large artboard (32232px heigh in my case) is exported or shared, some content near the bottom of the artboard is missing.

                                          Expected result:
                                          Attached as expected.png

                                          Actual result:
                                          Depends on the size.

                                          @1x edges are very pixelated. See attached result.png (even more noticeable for vectors; see icon.png)

                                          @2x some elements disappears. (mostly shapes with shadow and raster images) See result@2x.png (this button is built using two shapes - dark overlay which is still visible and "base" with applied shadow where only…

                                          1 vote
                                          Sign in
                                          Check!
                                          (thinking…)
                                          Reset
                                          or sign in with
                                          • facebook
                                          • google
                                            Password icon
                                            Signed in as (Sign out)

                                            We’ll send you updates on this idea

                                            1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
                                          • Don't see your idea?

                                          Adobe XD: Bugs

                                          Feedback and Knowledge Base