Adobe XD: Bugs

When filing a new bug, please provide:

  1. Version of Adobe XD
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. XD file, video or GIF capturing the issue (optional)

XD Known Issues list,
https://helpx.adobe.com/sea/xd/kb/known-issues.html#main-pars_text_2544517

Thank you.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Fonts not displaying correct weights after editing.

    I can confirm that https://adobexd.uservoice.com/forums/353010-adobe-xd-bugs/suggestions/13167330-font-rendering-with-wrong-weight-unless-editing is not fixed or has reappeared in my Adobe XD V: 15.0.12.8

    Fonts are selectively displaying weights after editing. During edit the font size/weight are as listed in the TEXT pane. Unselecting the text causes it to go to some "lowest weight" sizing.

    Thanks for your help.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  2. Delete multiple colors from palette not working

    version 15.0.12.8 (starter)

    Descp: Multiple selection is completely buggy on Windows 10. SHIFT or CTRL keys does not respond to user action as they should.

    This feature was working ok a few versions ago.

    See the VIDEO. Thank you!

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →

    Hi @Nonchalanto,

    Thanks for your report. Unfortunately, I’m not able to reproduce the problem in XD 15.0.2.8 – could you please provide a few more details?

    • System specification (Hardware make/model, Win10 version)
    • Are display drivers updated to the latest version? As well as any dedicated mouse and keyboard drivers?
    • Does this happen with all XD documents, or just one?

    Thanks,
    Joe

  3. equest for troubleshooting of the drag and drop problem

    1. 15.0.12.8
    2.To whom it may concern
    Hi, this is Yang who is the one of Adobe XD users.
    My co-workers and I try to use this program but we are currently in troble with minor problem.
    When I use it with a private computer, I am able to drag and drop elements to the ArtBoard. However, the function dosen't work with an office computer.
    The funny thing is that these two comupters are installed same version of Windows. Please let me know how to resolve this problem as soon as possible. I appreciate for your help.

    Sincerly,

    Soobin, Yang

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    limitation-with-workaround  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  4. Record preview stuttering

    Just did a 1 minute record preview of a self running sequence (no interactivity, just "fake" user usage). Sadly, for the first 10 seconds or so, there are "frozen" frames which looks stutter-y on playback. Very noticeable.

    Also, as an aside, would be nice to choose 30FPS instead of only 60FPS (maybe that option could save me right now).

    I can send the file direct, but as it's company work I can't post it here.

    Using MacBook Pro (15-inch, 2016), macOS 10.14.2 (18C54), XD 15.0.12.8

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. Adobe XD deleted my files

    I installed XD on Windows 10 but did not sign in into Adobe Cloud. Then I worked quite a whole day offline without Internet connection. After reconnecting to the Internet again, Adobe XS crashed and my files, icluding the folder they were stored in, disapeared. I rebooted my PC and a new shortcut icon had been placed on my desktop: "Adobe Creative Cloud".
    The "Adobe XD" icon on the desktop has lost its symbol - it's now white but still works. It's linked to "Adobe.CC.XD_adky2gkssdxte!App".

    The files are lost - I have lost a whole day of work.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →

    Hello Gerfried:

    Let’s see if we can figure out what’s going on.

    First, it’s not really possible to install Adobe XD without signing into Creative Cloud application. Can you confirm how you acquired the XD application installer?

    When you say XD crashed, what do you mean specifically? Were you working in XD at the time? Did you see any errors at the time?

    Finally, when you say you lost all your files is it that they are no longer visible in the Home Screen or Recent Files list? What folder location were the files being saved at prior to the application crash?

    Thanks for your help in digging into this!
    Nina
    Adobe XD

  6. Nudging with option

    Make it possible to move an object with the arrow keys when option/alt is pressed. Right now you have to release the key in order to move it but then you don't always see the pixel distances.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  7. Text Area mismatch between Windows and Mac

    Steps to replicate the issue:

    - Create a text area in Windows 10
    - Create rectangle and position it directly under the text
    - Save the file
    - Open the file in Mac

    Notice how the text has a different space to the top of the text area between the two systems.
    While viewing on Mac, you can clearly see the gap between the first line of the area and the rectangle.

    XD Version: 15.0.12.8, Creative Cloud 4.8.0.421
    Newest Roboto font installed on both systems.
    Bug present at least since May 2018

    screenshots: https://imgur.com/a/sXeDQDb

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  8. Error code 115 (Sketch file import)

    XD Version: 15.0.12.8
    Sketch file "appVersion":"52.6","build":67491 (from meta.json)

    Opening sketch file gives 'Error code: 115' - NB: your bug system search ignores numbers so it is hard to locate existing reports.

    Retrying a couple of times does seem to open it, however there are a number of layering issues / missing components (see screenshot).

    Sketch file available at https://www.lightningdesignsystem.com/downloads/#ui-kit

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →

    Hello Xander:

    I don’t have any issues opening on my end with XD 15. What I do see is there are some extra things that make it seem like things are missing.

    As the file was created in and for Sketch there may be items that XD interprets differently. I noticed for example, under “Color Tokens” there’s an artboard with a rectangle on top of the content. When removed, I see the color swatches.

    You may need to spend some time reviewing and edit content to suit the design.

    Hope this helps!
    Nina
    Adobe XD

  9. Error code 115 (Sketch file import)

    XD Version: 15.0.12.8
    Sketch file "appVersion":"52.6","build":67491 (from meta.json)

    Opening sketch file gives 'Error code: 115' - NB: your bug system search ignores numbers so it is hard to locate existing reports.

    Retrying a couple of times does seem to open it, however there are a number of layering issues / missing components

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  3 comments  ·  Flag idea as inappropriate…  ·  Admin →
  10. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
  11. Live Link slow/non-functional performance across all browsers and different computers.

    Hello, our live link prototype does not function properly. Clicking on linked elements in the live web preview does nothing, even though the hotspots show up as clickable. When we try to flip through pages of our wireframe via the pagination at the bottom, there's a huge lag on clicks and then the prototype will shoot forward 6 pages suddenly. As it stands, this live link is non functional; we can't use it to collaborate or gather feedback from non XD users, and as such it renders XD useless for us.

    I have the latest updated version of XD. This…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  12. Auto animate : Gradient Background Preview jagg and lag

    Problem: Jagged animation when showing to potential client.

    Xd problem : Background Gradient color transition using auto animate is lagged and jagged in preview mode. Using Macbook Pro 13". : v10.14".

    XD : v. 15.0.12.8

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  13. Version: 15.0.12.8

    Firstly, I'm brand new to XD so bare with me.

    When i link two art boards together and preview they transition fine but when I upload to my hosting site the links don't work.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  14. Download assets is not showing since the last update. HELP!!!

    Since the newest update, the download assets on the Adobe XD link that I share for developers are not showing anymore. Can someone please fix this?????

    Also, I double checked my artboards & assets in the assets section, and the things I need to show for download in the link, are marked as exports. They are just not showing in the link. I need to show these to my developers very soon. Please help!

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →

    Hi Rica-Marie Garcia -

    Sorry to hear this isn’t working as expected. Can you share a little more detail so we can investigate further? The following info would be helpful:

    1. What OS and version are you using?
    2. What version of XD are you using?
    3. What browser and version are you using?

    If you could also share your original XD file, that would help immensely. You can email it to AdobeXDSharingSupport@adobe.com.

    Some other things you can try:

    1. Create a new file, add a single image, mark it for export, and Share for Development. Can you download the asset from that URL?

    2. In the file you are seeing the issue with, unmark the assets for export, generate a new link, re-mark the assets for export, and update the new link. Does that change the behavior?

  15. Zoom to Selection on Line object fail and broke Undo/Redo

    Hello... Since e a few version (November, maybe before) I have noticed that if you have a single straight line selected. 0 or 90 degree and you do Zoom to Selection, it will not Zoom to it, it will also broke the undo/redo fonctionnality.

    Opening an closing the document, or the app bring it back.

    1. Adobe XD January release MacOS 10.13.6
    2. Create a doc, or open a doc. Draw a line at 0 or 90 degree with the line tool. Select it and do Zoom To Selection.
    3. Expect to Zoom to the line tool
    4. Actual results:…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  16. Drag x Click

    Version of JAN 28 2019

    When I make the drag transition, a slide for example, and the screen is down of top, if I make a tap on the card, the screen goes to the top, and do not make a transition.

    Just make the transition if the screen is on top.

    He hoped that the tap transition, when incorporated into a drag group, could be made in the same position as the screen.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  17. [Win] White Home screen, then hard exit on open

    I just updated to the newest Adobe XD version using the Creative Cloud tool. The installation appears to have worked fine. But when I start XD, it shows a blank screen and after a few seconds returns to desktop.

    The Application log from Windows shows the following:

    Faulting application name: XD CC.exe, version: 15.0.12.8, time stamp: 0x5c4934ba
    Faulting module name: XD CC.exe, version: 15.0.12.8, time stamp: 0x5c4934ba
    Exception code: 0xc0000005
    Fault offset: 0x000000000171067c
    Faulting process id: 0x41a0
    Faulting application start time: 0x01d4b94af94906ab
    Faulting application path: C:\Program Files\WindowsApps\Adobe.CC.XD_15.0.12.8_x64__adky2gkssdxte\XD CC.exe
    Faulting module path: C:\Program Files\WindowsApps\Adobe.CC.XD_15.0.12.8_x64__adky2gkssdxte\XD CC.exe
    Report Id: b3c4e54e-018c-460f-88d2-bd8e4d1daefa
    Faulting package full…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  6 comments  ·  System  ·  Flag idea as inappropriate…  ·  Admin →
  18. Auto animate performance bad on iPad (2017 models)

    We have 5 iPads, all 2017 models, and when prototyping and testing it out the performance is not that great.

    On the Live Preview the animations are super smooth, but on the iPad things move in a very jaggy motion (similar to the web version of auto-animate, although not quite as bad as that)

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  19. Underline

    Having issues with underline type, whenever I change the style within a paragraph of text, i'll save, close the document...when i open it the formatting is applied to another area of text (not the text i specified to be underlined). Same with copying artboards, the underline font appears in a different position of the copy.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  20. Slow Load with Blank Screen, Then Endless spinner

    When I run XD, I just get a blank white window. It takes a few seconds to see the Design.Prototype.Share. welcome screen. Sometimes, I kill it in Task Manager and restart.

    When I do see the welcome screen, I see an endless spinner in the Recent section and XD is doing something (the cursor is busy too). It never goes away.

    Killing it and restarting works. Happens nearly every time.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  5 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base