Adobe XD: Bugs

When filing a new bug, please provide:

  1. Version of Adobe XD
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. XD file, video or GIF capturing the issue (optional)

XD Known Issues list,
https://helpx.adobe.com/sea/xd/kb/known-issues.html#main-pars_text_2544517

Thank you.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Images are flipped upside down in pdf export

    I exported the file as jpeg and as pdf. In the pdf some of the images were flipped upside down inside the image container. I can only think that it is linked to the fact that I copied the images directly from a website without saving them first.

    I've attached the 2 files for you to compare and review.

    4 votes
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)

      We’ll send you updates on this idea

      bug-notXD-otherApp  ·  5 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
    • Firefox: links in broswer view are shifted when artboard is to long.

      Version of Adobe XD: 13.1.32.8

      Steps to reproduce the issues:
      - Create two artboards
      - Make the first artboard at least 5000px tall and add an element to it
      - Link the entire artboard to the other artboard
      - Save, then publish a prototype
      - Open the link in Firefox
      - Hover around the first artboard and you will find that the right side and bottom of the artboard is not linked (no pointer cursor).

      If the artboard is around 3400px tall or shorter the link does not shift. It seems that as soon as the artboard goes taller than…

      3 votes
      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)

        We’ll send you updates on this idea

        2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →

        Greetings Colin:

        Thanks for the detailed steps + XD file!

        I did some looking and here’s what I found. On the prototype you share, I am able to reproduce the problem you state. When opening the file in XD, I noticed that you had vertical scrolling enabled on both artboards. On the home artboard viewport was set to the height of the artboard (5000). I changed that to be 1080 and now when looking at the published prototype the bottom right shows that it has a link to another artboard. However, I do notice that along the right edge there’s a buffer where it doesn’t trigger the hand pointing cursor. https://xd.adobe.com/view/48fba056-d3c5-41bd-622d-907681ca931a-3eca/ (added a shape at the bottom right for visual reference).

        Looking into it more but hope the above helps in case you’re working with taller than 3400px artboards.

        Thanks!
        Nina
        Adobe XD

      • Error 44 when trying to update published Design Spec

        FIX THIS! I know you're aware of it, I've read what to do about mitigating it and nothing you suggest works. Your software is broken so stop screwing around and fix it, because you are costing all of us that took a chance with you time and money.

        And by the way, the fact that you haven't fixed this in months has convinced me that XD is going to end up bloated garbage like the rest of CC is now, so I will be doing all future projects with Sketch or Invision studio, because they fix their bugs in a…

        3 votes
        Sign in
        Check!
        (thinking…)
        Reset
        or sign in with
        • facebook
        • google
          Password icon
          Signed in as (Sign out)

          We’ll send you updates on this idea

          bug-needs-more-info  ·  3 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
        • shared prototypes not visible

          Please refer to the attached video.

          one of the stakeholders reported she couldn't see the new prototype at assets.adobe.com. I shared it with her. We found out, they appear when toggling to the listview and back, or when resizing the browser window.

          After a browser refresh, the same behaviour occurs. Only one prototype is visible, the others appear after resize or toggle list / grid view.

          Is this a known issue?

          2 votes
          Sign in
          Check!
          (thinking…)
          Reset
          or sign in with
          • facebook
          • google
            Password icon
            Signed in as (Sign out)

            We’ll send you updates on this idea

            2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
          • Artboard order in Design Specs

            I expect that in the design specs condivision the artboard order is the same I've assigned on the left panel.

            I can't figure which order the software is assigning during the condivision.

            2 votes
            Sign in
            Check!
            (thinking…)
            Reset
            or sign in with
            • facebook
            • google
              Password icon
              Signed in as (Sign out)

              We’ll send you updates on this idea

              bug-investigation-in-progress  ·  2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
            • Export x2, x3... version

              Version 13.1.32.8 in MacOSX
              When File > Export : web or iOS or Android , when I resize in x2, X3, etc. the resize is not x2, x3, etc. but /2, /3, etc.
              It's not "export to" but "designed to". In my french version "Conçu à". It's illogical with design logical and your Help : https://helpx.adobe.com/fr/xd/help/export-design-assets.html (see image file of your Help).

              1 vote
              Sign in
              Check!
              (thinking…)
              Reset
              or sign in with
              • facebook
              • google
                Password icon
                Signed in as (Sign out)

                We’ll send you updates on this idea

                0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
              • Your are offline at the moment (44:77:0). Unable to publish design link.

                When trying to share my Adobe XD file (2MB). One Artboard/Screen I get the Your are offline at the moment (44:77:0) error when publising a design link. I tried logging out, restarting, logging in, but no effect. When I open another XD File and publish it, it works fine. So it must have somthing to do with my file. I also tried activating/deactivating "include elements". No effect.

                Attached is the PDApp Log.

                1 vote
                Sign in
                Check!
                (thinking…)
                Reset
                or sign in with
                • facebook
                • google
                  Password icon
                  Signed in as (Sign out)

                  We’ll send you updates on this idea

                  bug-needs-more-info  ·  1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                • Prototype and design specs network error (71:-1:-1)

                  Hi, I've got this error as shown in the screenshot, I hope to get an answer as soon as possible, I attached the version of XD too.

                  Version 13.1.32.8 (Starter)

                  Regards

                  1 vote
                  Sign in
                  Check!
                  (thinking…)
                  Reset
                  or sign in with
                  • facebook
                  • google
                    Password icon
                    Signed in as (Sign out)

                    We’ll send you updates on this idea

                    bug-needs-more-info  ·  1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                  • Cannot update specs of my document

                    When updating a document's specs, this message appears.
                    When creating a new link for the specs, the same message appears.
                    Same type of error appears when sharing the prototype link.

                    I tried updating XD, it didn't fix my issue (Version: 13.1.32.8 on MacOS Mojave 10.14)

                    1 vote
                    Sign in
                    Check!
                    (thinking…)
                    Reset
                    or sign in with
                    • facebook
                    • google
                      Password icon
                      Signed in as (Sign out)

                      We’ll send you updates on this idea

                      bug-investigation-in-progress  ·  1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                    • Underline error in published prototype

                      I have a text block with underlined "links", preceded by bullets. It looks fine in XD, but in the published prototype the underline is gradually shifted, looking off as a result.

                      1 vote
                      Sign in
                      Check!
                      (thinking…)
                      Reset
                      or sign in with
                      • facebook
                      • google
                        Password icon
                        Signed in as (Sign out)

                        We’ll send you updates on this idea

                        0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                      • Design Specs stalling at 10%

                        Design spec pauses at 10 or 11%

                        1 vote
                        Sign in
                        Check!
                        (thinking…)
                        Reset
                        or sign in with
                        • facebook
                        • google
                          Password icon
                          Signed in as (Sign out)

                          We’ll send you updates on this idea

                          0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                        • Colors on Chrome

                          Hello.
                          When I look a prototype published on Chrome, images are darker than the reality. On all the others (Edge, Mozilla, Explorer...) colors are correct. Is it a bug fixed by a patch or something known ?
                          Thanks

                          1 vote
                          Sign in
                          Check!
                          (thinking…)
                          Reset
                          or sign in with
                          • facebook
                          • google
                            Password icon
                            Signed in as (Sign out)

                            We’ll send you updates on this idea

                            0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                          • Prototype share suddenly not appearing

                            Our designer has been sharing an XD prototype with great success until now - suddenly won't open in Chrome on my iMac (and did before) . Still opens OK on MacBook Pro. These errors show:

                            3-3aa4579535c2a83eccdd.js:1 Uncaught (in promise) TypeError: Cannot read property 'disable' of undefined
                            at _glDisable (3-3aa4579535c2a83eccdd.js:1)
                            at /view/338f6f0f-2d31-46d6-4906-7dc6399e75ac-45be/screen/c9977b57-452c-43a7-ad7b-b562c99a35e6/iPhone-6-7-8-Home-Menu/wasm-function[1815]:17
                            at /view/338f6f0f-2d31-46d6-4906-7dc6399e75ac-45be/screen/c9977b57-452c-43a7-ad7b-b562c99a35e6/iPhone-6-7-8-Home-Menu/wasm-function[870]:26
                            at /view/338f6f0f-2d31-46d6-4906-7dc6399e75ac-45be/screen/c9977b57-452c-43a7-ad7b-b562c99a35e6/iPhone-6-7-8-Home-Menu/wasm-function[1423]:34
                            at /view/338f6f0f-2d31-46d6-4906-7dc6399e75ac-45be/screen/c9977b57-452c-43a7-ad7b-b562c99a35e6/iPhone-6-7-8-Home-Menu/wasm-function[1740]:53
                            at /view/338f6f0f-2d31-46d6-4906-7dc6399e75ac-45be/screen/c9977b57-452c-43a7-ad7b-b562c99a35e6/iPhone-6-7-8-Home-Menu/wasm-function[1199]:281
                            at n._SpWebGLView_initialize (3-3aa4579535c2a83eccdd.js:1)
                            at g (3-3aa4579535c2a83eccdd.js:1)
                            at Fr.xr.initialize (3-3aa4579535c2a83eccdd.js:1)
                            at bundle-e2bafdbd7802ec411415.js:185
                            30new-relic.js:22 Uncaught Error: webglcontextcreationerror: Could not create a WebGL context, VENDOR = 0xffff, DEVICE = 0xffff, Sandboxed = no, Optimus = no, AMD switchable = no, Reset notification strategy =…

                            1 vote
                            Sign in
                            Check!
                            (thinking…)
                            Reset
                            or sign in with
                            • facebook
                            • google
                              Password icon
                              Signed in as (Sign out)

                              We’ll send you updates on this idea

                              0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                            • Tags on comments are not properly sanitized

                              When writing comments on Adobe XD, the sanitisation of the string (removal of possibly harmful script tags from the text) seems not to be done in the best way.

                              Some html tags are converted to plain text (like <div> or <b>) but some, including unrecognised tags, just disappear from the comment.

                              I found that when replying to a comment trying to use words between <> to state a dynamic text and that disappeared from the final comment. In the attachment is the same comment posted and when editing.

                              1 vote
                              Sign in
                              Check!
                              (thinking…)
                              Reset
                              or sign in with
                              • facebook
                              • google
                                Password icon
                                Signed in as (Sign out)

                                We’ll send you updates on this idea

                                0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                              • [Windows10] Issue when exporting technicals specifications

                                I get an issue when exporting technicals specifications on my project.

                                Only fifteen templates are shared on the web, not the entire project. And it is the same thing for all my project, all templates are not shared on the web, only a few ones... And I don't the number of sharing templates depends to the project.

                                You can see a screenshot in the attached file.

                                Anthony,

                                1 vote
                                Sign in
                                Check!
                                (thinking…)
                                Reset
                                or sign in with
                                • facebook
                                • google
                                  Password icon
                                  Signed in as (Sign out)

                                  We’ll send you updates on this idea

                                  1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                                • Error sharing design specs

                                  Error sharing design specs.

                                  Adobe XD 12.0.12.10
                                  Creative Cloud Sync 4.0.1.60
                                  Erro generating or updating specs link.
                                  Artboards: 33
                                  File size: 30,8 MB

                                  1 vote
                                  Sign in
                                  Check!
                                  (thinking…)
                                  Reset
                                  or sign in with
                                  • facebook
                                  • google
                                    Password icon
                                    Signed in as (Sign out)

                                    We’ll send you updates on this idea

                                    3 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                                  • 1 vote
                                    Sign in
                                    Check!
                                    (thinking…)
                                    Reset
                                    or sign in with
                                    • facebook
                                    • google
                                      Password icon
                                      Signed in as (Sign out)

                                      We’ll send you updates on this idea

                                      2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                                    • Design specs latency

                                      There is a lack of latency on the design specs section.

                                      1 vote
                                      Sign in
                                      Check!
                                      (thinking…)
                                      Reset
                                      or sign in with
                                      • facebook
                                      • google
                                        Password icon
                                        Signed in as (Sign out)

                                        We’ll send you updates on this idea

                                        0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                                      • Cant Create a New Deisgn Spec

                                        1. Adobe XD Version 11.0.22.10

                                        2. On an existing cloud saved project, go to "Publish Design Specs", include assets, and hit "New Link"

                                        3. I would expect a new design spec to upload and be published, that I can then share.

                                        4. It uploads all the way to 100% and then tells me it could not update my design spec (even though I'm creating a new one, and I've also deleted the old spec) and gives me the error 44:47:0. After this, if I try publishing a new link again, it tells me that "There was a problem creating our…

                                        1 vote
                                        Sign in
                                        Check!
                                        (thinking…)
                                        Reset
                                        or sign in with
                                        • facebook
                                        • google
                                          Password icon
                                          Signed in as (Sign out)

                                          We’ll send you updates on this idea

                                          1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                                        • WebGL error when trying to view online

                                          I cannot view Prototypes on the web in our main conference room through Chrome. I checked and it is fully updated. I don't have this issue on any other system and I have tried multiple different XD projects. Other browsers can preview them fine.

                                          bundle-4c5f7f1a21d44ccbb21c.js:130 TypeError: Cannot read property 'disable' of undefined
                                          at glDisable (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at Lb (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at ac (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at Hs (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at OS (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at bn (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at Nr.initialize (2-8ea5eb90decc8fa9c3ba.js:1)
                                          at Object.t.initializePlayer (bundle-4c5f7f1a21d44ccbb21c.js:37)
                                          at t.value (bundle-4c5f7f1a21d44ccbb21c.js:185)
                                          at e.notifyAll (bundle-4c5f7f1a21d44ccbb21c.js:130)
                                          at d.close (bundle-4c5f7f1a21d44ccbb21c.js:145)
                                          at d.closeAll (bundle-4c5f7f1a21d44ccbb21c.js:37)
                                          at d.perform (bundle-4c5f7f1a21d44ccbb21c.js:37)
                                          at x.perform (bundle-4c5f7f1a21d44ccbb21c.js:37)
                                          at x.perform (bundle-4c5f7f1a21d44ccbb21c.js:23)
                                          fn…

                                          1 vote
                                          Sign in
                                          Check!
                                          (thinking…)
                                          Reset
                                          or sign in with
                                          • facebook
                                          • google
                                            Password icon
                                            Signed in as (Sign out)

                                            We’ll send you updates on this idea

                                            0 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
                                          ← Previous 1
                                          • Don't see your idea?

                                          Adobe XD: Bugs

                                          Feedback and Knowledge Base