Bug details

Extensis Suitcase Fusion 9 Not syncing adobe fonts to XD

Windows 10 (current version/updates)
Adobe XD (latest update)

My Adobe fonts will not work in XD when using Suitcase Fusion 9 to manage Adobe fonts. Every other adobe app works fine but XD chooses to not show the Adobe fonts even though they are activated. Or when it does and you select one nothing happens (font does not change in XD). I have tried deactivating and reactivating fonts, uninstalling and reinstalling XD, reinstalling Fusion 9, everything!! I just want the fonts to work so I can use this app!
This is soooo problematic because I will be working on a file just fine but then open the XD file the next day and all the fonts will be different with no warning. Someone else coming into the project would have no idea that the fonts were not working because there is no real indicator that the fonts are missing.

2 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

SIlvernail shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

2 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • SIlvernail commented  ·   ·  Flag as inappropriate

    Hello Rakesh,
    Thank you for the reply. Unfortunately the issue is not with the font management software. We have tried using several other font management programs and we are left with the same result. Some fonts activated in XD and some are not. Sometimes the font appears in XD, but when you select it XD says it is missing in the new font area in the assets panel. There is something wrong with how XD is talking to font management programs on windows and it is making it very difficult if not impossible to use. Please advise on when this issue is going to be tackled. It has been way to long. Thank you.

  • AdminRakesh Lal (Software Engineer, Adobe) commented  ·   ·  Flag as inappropriate

    Hi,

    We tried recreating the bug at our end, and we see the Adobe created font getting activated-deactivated in Suitcase Fusion 9 and it reflects in XD also. But other fonts are sometimes not working correctly. The same is observed in other applications as well. So it seems its a bug with Suitcase Fusion 9.

    We request you to raise a defect with Extensis Suitcase team.

    Thanks,
    Rakesh Lal

Feedback and Knowledge Base