Bug details

getSharedResourcesFilePath(): Could not load component: Code: 52

Due to a OS Crash I had to reinstall Adobe XD. Now, when attempting to load a cloud-saved file, it fails to do so, and the following error message is displayed as a popup:

getSharedResourcesFilePath(): Could not load component: Code: 52

Upon clicking the "OK" button, a new file is open and automatically saved to the cloud as "Untitled".

Version of Adobe XD: 14.0.42.14 (Starter)
Version of Creative Cloud: 4.7.0.400
Version of Creative Cloud Sync: 4.1.0.29
Windows 10 Pro Version 1703 8GB RAM

Steps to reproduce the issues:
1. Launch Xd.
2. Click Cloud Documents > Desired File.
3. Click OK.

Expected result: File is loaded business as usual.
Actual result: Error message: "getSharedResourcesFilePath(): Could not load component: Code: 52"

12 votes
Sign in
(thinking…)
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

Mauricio Paternina shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

14 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • bodiot commented  ·   ·  Flag as inappropriate

    hello

    I have the same problem under mac os
    « get sharedresourceFilePath(): could note load component: code:52 »

    but I can not recover the file
    can i duplicate it from the cloud or else ?

    mojave 10.14.4
    xd 18.0.12.9

    Thanks
    Franck

  • Clark Justine commented  ·   ·  Flag as inappropriate

    Also if it would help I have encountered this problem after a software conflict problem that requires me to delete a file from %appdata%, which I stupidly deleted all the files in there.

  • Clark Justine commented  ·   ·  Flag as inappropriate

    I have encountered the same error Error message: "getSharedResourcesFilePath(): Could not load component: Code: 52"

    I have tried to also to uninstall XD and fresh install the XD removing all traces still with the same problem.

    However (for windows) I noticed that I still have the copies of the files online on my account and that the problem only is when I opened files that I have saved from to the cloud.

    So what I did is I went to my "Cloud Documents" deleted the files that I am unable to open and then went to "Deleted" look for the file that I recently deleted and selected the file and clicked on restore (upper right corner). I am now able to open all the files. Basically, delete then restore the files and it should load up all the restored assets.

    Please do this with caution since I can not guarantee that it will work for you as well.

    - Please vote on the bug report above.

  • heidi commented  ·   ·  Flag as inappropriate

    Experiences the same issue recently. Shared a file with a colleague and I couldn't reopen it after he edited it. We are using the same XD version but I'm using macOS High Sierra Version 10.13.6 and he uses macOS Mojave 10.14.3

  • Carl commented  ·   ·  Flag as inappropriate

    I'm on a Mac, OS 10.13.6. When I try to open the cloud file I created, I get the error code

    getSharedResourcesFilePath(): Could not load component: Code: 52

    My co-worker, with whom I shared the file, has no problems opening and editing the file.

    Any news regarding this? It's seriously messing up the workflow. You should consider rolling back this option until it functions properly.

  • Erik commented  ·   ·  Flag as inappropriate

    1. 14.0.42.14

    2. Shared a file with a coworker of mine on the same network. I can no longer open the file after changes were made on their end.

    3. I should see the work that has been updated and access the file.

    4. Receive error code attached. File crashes and closes.

  • Geneviève Desautels commented  ·   ·  Flag as inappropriate

    Bullet 2 «Go to Settings> Storage control panel, click on link “Change where new content is saved” to C:»… seems for PC, what about Mac?

  • Rhasya Bintang commented  ·   ·  Flag as inappropriate

    please help, i need a solution. why when i open my file that i was save in cloud document is always pop up this message "get shared resource file path():could not load the component" and always make a new file name "untilted"

  • Adedoyin Akande commented  ·   ·  Flag as inappropriate

    Alright, so same happened to me too.
    What you do is:

    1. Open Creative Cloud app in a completely different Computer Device
    2. Sign in with your account (The one holding the cloud document that is now throwing the error)
    3. Make sure the Adobe XD on this new device is updated
    4. Open Adobe XD, Click on "Cloud Documents" you should see your file now(The one that got currupted)-> Open it
    5. Click the Hamburger menu and then do "Save As" (This lets you save the file locally)

Feedback and Knowledge Base