Bug details

! Empty Symbols and Differences between instances

Using Adobe XD 11 and Mac OS High Sierra 10.13.6 (macBook Pro 15" 2017)


I was working on a project, and while I was editing a symbol I accidently deleted an element. I clicked Cmd+Z to revert, but no matter how far I undo, it will never bring it the element back.

Then I went to the assets panel to see what happened to that symbol, It showed that it was being used 35 times, but couldn't find it anywhere in the design file.

I then dragged the symbol to pasteboard because it disappeared on all artboards. It shows through layers that the symbol is basically empty and there is nothing inside, I also can not add anything inside.

Finally I closed the file and opened it again, I see some symbols have the element and some don't.

I have attached the file, go to assets panel and see symbol labeled 'footer'
if you right click and highlight. it will show only instances inside masks, but that's it

1 vote
Sign in
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

Armando Scuro shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Password icon
Signed in as (Sign out)
  • Armando Scuro commented  ·   ·  Flag as inappropriate

    Ok so i think i was able to reproduce this bug, although not exactly through the same means

    what I did was
    - create a symbol out of a rectangle 1024 x 46 #000000
    - go inside symbol and select the rectangle
    - click enter so i can edit the vector points of the rectangle
    - press Delete on the vector points one by one until all deleted
    - you will then have an empty symbol that behaves similarly to the original file i posted

    Still doesn't explain why in the original file it was available inside masks, but its something

  • Armando Scuro commented  ·   ·  Flag as inappropriate

    Hi Nina, no I have not encountered this bug on any other file. All my attempts at recreating it have resulted in nothing but failure.

  • Armando Scuro commented  ·   ·  Flag as inappropriate

    Hi Nina, no I have not encountered this issue before, but tbh, after updating to August release this was the only file I worked on extensively.

    I understand it’s hard to recreate as even I can not pinpoint exactly how it happened. I too will try to recreate it from my end.

    Anyway hope the undo bug is fixed at least in future releases and do update if anything’s turns up.

    Thanks, appreciate all the hard work

  • Armando Scuro commented  ·   ·  Flag as inappropriate

    Hi Nina, the Footer symbol is supposed to have one element which is black rectangle of 1024x46. That’s it

    And yes, the whole issue started when Undo skipped the deletion of the footer element and will not bring back what I accidentally deleted. It did undo stuff before that but not the footer thing.

Feedback and Knowledge Base