Bug details

Symbol, prototype link bug

If I create a symbol and have a prototype link within it, like a footer (see attached), I then use that symbol as a repeatable object throughout my designs it follows that the link should be on every art board on every footer as that is why I created a symbol, so I wouldn't need to link 100 times over. If I didn't wan't the same function from one footer I would ungroup (not make it a symbol any more) and customise the links I needed.

1 vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

James shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Hello James:

I’m not sure I understand what you’re describing. Are you trying to add hyperlinks? Currently there is no support for this.

Looking at the project you’ve included, I’m able to insert multiple instances of the symbol and it shows all the included design elements.

Can you update with detailed steps of what you’re trying to do, as well as details of where it’s not working the way you’d expect.

Thanks!
Nina
XD Community Quality Manager

1 comment

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • James commented  ·   ·  Flag as inappropriate

    To clarify Nina... (Please use the file attached.) There are actually a couple of issues:

    1) If I edit the master symbol (footer) and create a prototype link (in prototype mode) I think all footer symbols across the whole of my prototype should update instantly.

    2) If you create a prototype link from the footer symbol on art board 'Link 1' and then create the same link from the same newsletter box on art board 'Link 2' then you cut (CMD X) the newsletter box with the prototype link from the footer symbol and paste it back in the prototype link has disappeared. I think the link should stay.

    PS Just realised I can't attach a file - can you drop me an email directly and I'll share the file please.

Feedback and Knowledge Base