Bug details

Can't save project

<<The document “Untitled 2” could not be saved as “Untitled 2”>>.
I tried other names and tried saving it to different locations, but it didn't work.

28 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    29 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Sherin Biju commented  ·   ·  Flag as inappropriate

        From yesterday on wards I'm having the same problem. I'm unable to save the XD file, even tried in different locations but the same error message was popped up. Please fix this bug, as hours and hours of works were there and suddenly the error message pops up to give us a heart attack. I've been using XD from around 6-7 months.

      • Julie commented  ·   ·  Flag as inappropriate

        Have the same issue today.
        MacOS Sierra 10.12.6
        Adobe XD Version 12.0.12.10

        New file today, saved fine on first save, but every try after that I get error message saying the file cant be saved as [filename]

        When I closed the file without saving and tried to reopen it, i get another error message: 'Error code 48: This is not a valid XD document.'

      • Silviu commented  ·   ·  Flag as inappropriate

        Hi Nina,

        I'm saving the files in a different drive than the one where XD is installed.

        Maybe I wasn't clear with my fist comment. I am able to open the file from both the folder it's located and from Recent Files in XD. The trouble is that it's an older version of the file. I've worked ~10h more after this version and it's like the work has vanished. XD didn't show any error when saving the file, so I closed the app and the next day I opened it back to find this bug.

        In the temp folder you mentioned there is only an XD file with the basic tutorial of the app.

        - XD build version: 7.0.12.9, but I had the previous version when the bug occurred (an update came the same day)
        - Windows 10 Home, Version 1709, OS Build: 16299.309
        - save path: E:\_Graphics\_Projects\Company name\Web

      • Cengiz Polat commented  ·   ·  Flag as inappropriate

        Hi Nina,
        I didn't use Adobe XD since a while and i remember, that after a few updates, the problem was solved. I believe, the problem was that the project emwas very big because i opened a lot of svg files in my specific project
        - It did run on february 2017 windows 10 pro

        - no
        - save location. Local but tried usb disk too

      • Silviu commented  ·   ·  Flag as inappropriate

        This happened to me as well. The big issue is that XD didn't show any error that it can't save, so I thought everything is in order. When I opened the doc today I noticed that it's a version that I had a few days back, so I lost about 10h of work on it.

        I was able to publish the project before closing the app and online it's the latest version. Can I somehow retrieve that on my PC?

      • AW commented  ·   ·  Flag as inappropriate

        This happened to me on windows 10. I was getting an error doing a straight "save" but then it looked as if it worked on a "save as". Used "save as" numerous times while working over the course of a few days. I closed down my machine last night. Opened it up this morning and opened my document. NOTHING WAS SAVED. I lost about 20 hours worth of work. So devastating. Is there any way to recover temp documents and get my work back? This is a huge hit to my deadline.

      • V commented  ·   ·  Flag as inappropriate

        Mine wont let me save on windows 10, and now I can no longer open my projects.

        I get and error stating: "Cannot load the specified document."

        Please help. I really need to open this file and I don't know what to do.

        Is there a fix to this issue on Windows 10?

      • JH commented  ·   ·  Flag as inappropriate

        Same with me, can't save new or existing files. Pretty big bug we've got there. Nearing shift to a different product so we can continue work - please update on bug status if possible.

      • Cengiz Polat commented  ·   ·  Flag as inappropriate

        I'm on Windows 10.
        I will get everytime this error when i get to a special amount of data in my project. Wanted to have a lot of different icons on my board. Everytime after i come to ~80-120 icons, this file seems to be having problem to handle the amount of data. The max size of my file which i could save stays with 3.22 mb. I hope this will help to find the bug or i used tbe program wrong.

      • Reece Goddard commented  ·   ·  Flag as inappropriate

        Tried copying, closing, updating, creating new, and pasting into a new file. It worked at the time. However this morning I went to the prototype tab, for some reason it showed the onboarding page, after closing that all of the prototype work for 76 artboards had been deleted... and none of my projects can save now.

      • Cat Templeton commented  ·   ·  Flag as inappropriate

        If anyone else has this issue, copy your artboards to the clipboard before closing without saving, then paste them back into the document - This saved me a toooon of work.

      • Will commented  ·   ·  Flag as inappropriate

        I'm also having this same issue. Unable to save my file after the weekend.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I am also having this problem. Message comes up saying "The document <filename> could not be saved as <filename>." Have tried removing special characters, have tried copying into new document...

      • Anonymous commented  ·   ·  Flag as inappropriate

        So this is happening with others too...That's bad. I can't save or open anything as of today.

      • Edwin Delgado commented  ·   ·  Flag as inappropriate

        Can't save anything, or new files. Copy paste into a new document, and created a new one, with no success. App is updated. I'm getting same error "The document --- could not be saved as ---"

      • Nick commented  ·   ·  Flag as inappropriate

        I can't save already open or newly created documents. I also can't open any existing documents.

      • Nick commented  ·   ·  Flag as inappropriate

        I'm also having this issue, I'm on MacOS Sierra 10.12.3 and Adobe XD 0.6.12.17 Beta.

      ← Previous 1

      Feedback and Knowledge Base