Bug details

SVG Export compatible with Android Studio

Android support vectors which is very nice as you only have to manage one version of the asset, and some other cool things. I am aware that most people use PNG for now, but this is changing and new projects are leaning toward vectors.

Now the issue is that Android Studio is a bit dumb when reading SVG files, and the only tool that export compatible files is Sketch (and I am trying to switch to Adobe XD completely, especially because there is a Windows version incoming).

So I have done many tests to figure out what's "wrong" with XD:

- Android Studio support only inline styles, and can't read styles from the <defs> tag.
- I opened the file with Adobe Illustrator, then exported again, using the Inline style setting, and I got better results, BUT:
I really don't want to post-process my files using AI which is counter productive, and also because AI is still defining the transparent background with a style class, and since Android Studio cannot read it, my background is not not transparent, but white.

I was thinking that we could have a radio button when exporting as SVG, which let you select Inline styles (with an empty <defs> tag) or Internal CSS

If you want to contact me, I'd be happy to run tests and help as much as I can.

I have attached 3 svg files, the only one that run correctly is the Sketch one.

30 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Ludovic Vialle shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    28 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Dashanan commented  ·   ·  Flag as inappropriate

        The description of this bug and its comments are not related at all. Looks like somebody from the XD team merged two submissions incorrectly. So what exactly is the bug-fix-in-progress? The Android SVG icon issue - or - the Adobe XD app issue?

      • shikha commented  ·   ·  Flag as inappropriate

        What ever things created in xd when converted in svg , icons per say doesn't support in angular or android studio. And this issue is there from a long time. Don't know when you people are going to resolve this issue.

      • coudor commented  ·   ·  Flag as inappropriate

        I have the same problem. I have an imac, i use android file.
        the adobe xd application prevents me to change my use of the USB port from "loading" to "multimedia transfer".
        I finally tried to uninstall the XD application, but despite the uninstallation, a "ghost" window of the adobe XD application still appears and interferes with the transfer ... (while it is unmounted).
        Help ! Will I be able to retrieve my phone and transfer my items back to my mac?

      • Kasim Sheyi commented  ·   ·  Flag as inappropriate

        Simple thing to do is to close Adobe XD on your PC, make sure it is not running. Thats the fix for me

      • Anonymous commented  ·   ·  Flag as inappropriate

        This issue is still there, I've found a little bit better workaround, export SVG from XD, then open it in Sketch and then export it from sketch - voila, then it can be imported by android studio

      • Harry commented  ·   ·  Flag as inappropriate

        When will this be fixed? I'd like to use XD, and now I need to recommend that we not purchase the product.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Since the time I installed XD on my desktop, I have been unable to use my Android phone to just transfer files normally. I get a message popup asking, ""Open Adobe XD when this USB device accessory is connected?" If I choose CANCEL, then the phone goes back to the charging-only mode.

      • Josiah Schaefer commented  ·   ·  Flag as inappropriate

        For me it worked once I closed out of Adobe XD and stopped the program rather than uninstalling it. Hope that helps someone else.

      • Mateusz commented  ·   ·  Flag as inappropriate

        Adobe XD 1.2.6
        Android 7.1.1
        OnePlus 5
        OSX 10.12.6

        I installed XD to try out tethered preview, but uninstalled it after a few hours. After uninstall, I get the message "no apps work with this USB-accessory" (translated from Swedish) when I connect with USB. Same OS, same cable, same Droid version, only XD install/uninstall has changed. The error message also gives a link to the Play Store page for XD, which is why I'm guessing it's the culprit.

        I've restarted the phone and emptied app cache, and regardless of which USB mode (including dev mode) I've selected, I get the same error.

        Any advice?

        Cheers / M

      • ARIHANT commented  ·   ·  Flag as inappropriate

        This is expected. Android File transfer will never work along with Adobe Mobile XD.
        One need to uninstall Android File Transfer in order to run Adobe XD.

        Regards,
        Arihant

      ← Previous 1

      Feedback and Knowledge Base