Adobe XD: Bugs (Read-Only)

PLEASE NOTE THE FOLLOWING CHANGE FOR BUG REPORTS

IMPORTANT: User Voice Bugs forum is now read-only. To learn more about this change, visit https://adobexd.uservoice.com/forums/353010/suggestions/38475424

You can reach our support team in the following:
- Adobe XD Community Forum, https://forums.adobe.com/community/adobexd

For current XD Known Issues list visit,



Thank you!
Adobe XD Team


  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Copy paste from Illustrator doesn't work

    Copy/paste a shape with an outline and a transparent fill from illustrator to XD doesn't produce anything.

    It works if there is a fill or if I expand the appearance.

    It seems that the bug exists only with a transparent background.

    Mac OS 10.14.3
    XD 18.2.12.2

    4 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  5 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  2. Gradient direction is different when saved into assets panel

    When I'm trying to use a gradient from my assets it works, but not in the direction I saved it in.

    1. Created gradient on shape
    2. Added gradient to assets (the preview in the assets shows how I saved it, in the correct way)
    3. Applying this gradient works, but the direction is from top to bottom instead of left to right.

    Feel free to ask for more information! Added a image, right button is how it is applyed while it should apply like the left button.

    4 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  3. Font size mismatch in Windows

    I use XD for Windows Desktop design. Our products use the Windows default font (Segoe UI 9pt) in most situations. However, when I specify this font in XD it appears too small, and I have to offset it to 12pt to get it to match what I see in Windows.

    To reproduce:
    1) Take a screen capture of a generic Windows UI element that uses the default Windows font (Segoe UI 9pt)
    2) Paste the screenshot into XD
    3) Redesign the text elements in XD using Segoe UI 9pt font - the rendered text is too small
    4) Change the…

    4 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
    bug-filed  ·  Bear Travis responded

    Hi there,

    Thanks for getting in touch. Units in XD can get a little confusing if you look closely enough. There was a bit of a conversation earlier on the forums 1 about what the units actually are. And while we call them a “virtual pixel”, they do tend to map to an OS-specific concept. On Windows, this is the DIP (Device Independent Pixel) 2. There are 96 DIP in an inch, and 72 Pt, so the conversion is font size in DIP * 72 / 96 = font size in points. Using DIP allows us to keep all the measurement units in XD the same (x, y, width, height, font size, line spacing, etc). In the future, we’ll work towards adding more unit flexibility, but hopefully that will help you at least understand the current state of the world.

    -Bear

    1 https://forums.adobe.com/message/9786592
    2 https://msdn.microsoft.com/en-us/library/windows/desktop/ff684173(v=vs.85).aspx

  4. Copy Paste artboard as PNG instead of svg code

    Previously, when copying an artboard and pasting in slack or Jira, it would paste the image as a png file. This was incredibly handy as it kept me from having to export the artboard. I could just copy and paste the image in another program. NOW, when I copy an artboard and paste in another program, it pastes the SVG code instead of the image. This is so so frustrating and has really slowed down my workflow

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  5. Importing designs failed

    I try to export artboards from XD to Zeplin, I got an error called " Importing designs failed "
    why it has occurred?

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  6. XD export to Zeplin not working. (MacOS)

    After selecting an artboard and exporting it to Zeplin. Only Zeplin application opens, files don't get exported.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  8 comments  ·  Plugins  ·  Flag idea as inappropriate…  ·  Admin →
  7. Assets, color picker is missing

    I just install Adobe XD 19.1.22.6
    and follow the introduction tutorial (in app and video)

    In step 09, I notice that in the asset panel, when right click on a color and select "Edit", there is no more the color picker (pipette icon).

    I guess that would be handy to put it back.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  8. When reordering arboards, the pastboard keeps getting selected in the layerspanel for some reason

    For some reason the pasteboard keeps being selected and I am unable to deselect it. Deselcting is only possible when reordering the arboards through keyboard shortcuts.

    Video showing the issue: https://www.youtube.com/watch?v=0vA82xDeMxc

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  3 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  9. Repeat grid missing after export to jpg

    I discovered that some of my repeat grids are missing after exporting to jpg.

    For example, I have very long page for some project (25000px height) and there are multiple repeat grids on same page. I made first one and copied whole repeat grids 3 times. After I export my design as jpg, the 1st and 2nd one are there, but 3rd one is missing after export. I tried to move my 3rd repeat grid up, just bellow 2nd one and then it's there, but that's not option for me, I need this repeat grid at the end of the…

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  10. Crash trying to rename a layer by double-click

    Adobe XD 16.0.2.8, Windows 10,

    Renaming of any layer by double-click leads to crash (seldom).

    I cannot reproduce it easily by many double-clicks, but 2 per an hour Adobe XD crashes on my attempt to rename some layer by double-click.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  6 comments  ·  Flag idea as inappropriate…  ·  Admin →
  11. Adobe Illustratorからコピペすると、フォント情報が正しく引き継げない

    # 再現方法

    1. Illustratorで「ABCD」とテキストをうち「游ゴシック体 Bold」を指定
    2. XDで新規ファイルを作成
    3. 1のテキストをコピーして2にペースト
    4. [発生] 貼り付けたテキストが「游ゴシック体 bold」(※Bが小文字)になっており、フォントの表示が正しくない。
    5. 4のXDファイルを名前をつけて保存し、閉じて、開く
    6. [発生] 「1個のフォントが見つかりません。環境にないフォントを表示」というエラーメッセージが出て、「• YuGothic-bold」が無いと言われる。

    # 問題点

    Illustratorからコピペした場合にきちんとフォント情報が正しく引き継げていません。
    その他の日本語フォントでも起こります。
    エラー部分で表示されるフォント名もUIの表記と合わせて日本語にするべきではないでしょうか?

    # 環境

    XD 15.0.12.8
    Illustrator 23.0.1

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  System  ·  Flag idea as inappropriate…  ·  Admin →
  12. Downscaled images exports blurry

    There is a problem with large images imported into XD when I resize (downscale) an image in XD and export it, it becomes blurry.
    I know I can resize it in PS into precise size but it's not a good way to doing it because I may resize the image multiple times in XD due to the design process and every time I resize an image in XD I should go to PS and again resize it and again import it into XD.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  13. Share for Review - Error 44:23:0

    Have tried to publish the prototype three times now and I have received this same error through each attempt.

    I was able to publish the design specs as well as share the document but am only unable to share for review.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →

    I think the file size + all artboards marked for batch export is the problem. The error code usually means there’s an issue with too many assets.

    I’ve filed a bug for investigation on our end. In the meantime, the best thing to do would be to break this up into a few files to help with the file size.

    Apologies for the inconvenience. Hope this helps!
    Nina

  14. shared prototypes not visible

    Please refer to the attached video.

    one of the stakeholders reported she couldn't see the new prototype at assets.adobe.com. I shared it with her. We found out, they appear when toggling to the listview and back, or when resizing the browser window.

    After a browser refresh, the same behaviour occurs. Only one prototype is visible, the others appear after resize or toggle list / grid view.

    Is this a known issue?

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
  15. Cannot click through invisible parts of a layer on design specs

    When browsing a Design Spec, devs cannot click on layers underneath objects with no fill.

    The example linked below shows a group of three objects. The green one being a border only layer above all others. On Design specs I cannot see specs for any of the ones below that layer because all clicks (even when the layer has no fill) are caught by the top layer.

    https://xd.adobe.com/spec/89db1075-a448-4e44-a452-0bf117c8d898/#screen/dd5b3bad-31a6-46fb-a90c-e6bab8da2a8a/Artboard%20%E2%80%93%201

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  16. Repeat Grid inside Symbol cannot have different text in each copy of symbol

    I have the following layer structure

    - Symbol
    .... - Headline
    .... - Repeat Grid
    ........ - Text (This is where the bug occurs)
    ........ - Shape

    I have this symbol inside multiple art boards.

    The text instance override inside the repeat grid only works for the first grid item (i.e. the source item).

    If I change the text in any other repeat grid instance, it is propagated across every symbol.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  17. Cloud Documents - XD vs Web View

    I see different sets of files saved to the Cloud in XD (when opening a file) and in the web view (when you go to Creative Cloud app, then Files -> View on Web).

    See the attached image. The screenshot has been taken immediately after opening both windows at the same time. Left side: Web view (in the browser), right side: XD Open File view.

    Note that both lists are sorted by name. In XD I see twi "Dialog 004 Users v4" files, in the web view - just one. In XD I see 3 "Dialog LIBRARY v4" files, in…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  18. Cannot Rename objects, or Art boards, Xd freezes then crashes

    XD Version: 21.1.12.3
    OS: Windows 10

    At Present I am unable to rename any object, group, component, or art board in XD. I can double click and right click to rename it but XD doesn't accept keyboard input, or when it does it appears to white out the height or width of the attribute editor panel.

    Restarting XD only appears to reset the bug and it will begin happening after a short period of work. In a recent rare case I was no longer able to deselect an object to rename another which resulted in XD crashing.

    I can't share…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  19. Jira user with apostrophe has page update issue with Adobe XD add-on

    We experience an issue with Adobe XD for Jira add-on.
    We believe the issue is potentially caused by apostrophe in Jira username.

    After installing the add-on, this particular user sees page ‘freezing’ whenever she updates the ticket such as comment.
    The comment gets published, but she has to refresh page to see the update.

    She can reproduce the issue on two different machines (MacOS, Windows) with different browsers.
    Below is the error message in console log.

    Note, when we disable the add-on, the issue goes away.

    Jira version: 7.13.0
    Jira Core version: 7.13.0

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  20. open document your computer broken

    When I go to open a document from my computer the tab does not display anything. I have to click to another tab and then back to my computer again to get the modal window to display. XD version 20.0.12.11

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  Core Design  ·  Flag idea as inappropriate…  ·  Admin →

Feedback and Knowledge Base