Adobe XD: Bugs

When filing a new bug, please provide:

  1. Version of Adobe XD
  2. Steps to reproduce the issues
  3. Expected result
  4. Actual result
  5. XD file, video or GIF capturing the issue (optional)

XD Known Issues list,
https://helpx.adobe.com/sea/xd/kb/known-issues.html#main-pars_text_2544517

Thank you.

Bug details

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Layout grid (not square grid) stop working in design spec (share for development)

    Switch "layout grid" on design spec don't show layout grid despite position "switch on". We checked this issue on several browser. Layout grid disappeared on Chrome ver. 72.0.3626.12 1 and earlier versions. Believe we know differences between layout grid and square grid;) Take a look at the screens attached(safari and chrome).
    Take it seriously, please.

    5 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
  2. Unable to select multiple layers across multiple groups

    If two layers live in different groups, it's not possible to select them both. A use case for this is attempting to change the fill color for multiple layers, but they all live in different groups. This is standard functionality in other design tools.

    See screen recording: https://www.dropbox.com/s/98yflc2nz9w3xlw/select-from-multiple-groups.mov?dl=0

    ^ I'm holding the Command key while trying to select multiple layers.

    It seems this bug was marked as "by design" in a previous post, but I'd like to raise the issue again since this is a major pain point for me. Anyone else agree?

    https://adobexd.uservoice.com/forums/353010-adobe-xd-bugs/suggestions/17260256-selection-across-groups

    4 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    resolved-by-setting-update  ·  2 comments  ·  Design  ·  Flag idea as inappropriate…  ·  Admin →
  3. Over 500% CPU usage when using cloud documents that share symbols

    I have my design system file stored in cloud documents and syncs fine when it is open by itself. The trouble starts when I simultaneously have a separate XD document open using symbols from the design system file (in cloud documents) and something gets saved in the design system file CPU usage goes to like 500%+. If both files are local, this does not appear to be an issue.

    MacOS 10.14.3
    2.8 GHz Intel Core i7
    16 GB 1600 MHz DDR3

    2 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  4. "include assets for download" is greyed out, even though I have marked for export.

    I have marked several items for export, then I went to "Share for development" and the option to "include assets for download" is greyed out. As far as I understand it should be available.

    1 vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Share  ·  Flag idea as inappropriate…  ·  Admin →
  5. comments truncated

    Guest comments are truncated and not viewable. I'm can not view entire comments.

    1 vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    resolved-by-setting-update  ·  2 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  6. Holding spacebar + mouse drag does not move the artboard

    This is a unique situation that only seems to happen inside a virtual machine. I am using VirtualBox version 5.2.20 r125813 (Qt5.6.2).

    When attempting to move around the artboard using the space bar + mouse drag it doesn't work. It does display the 'hand' icon but the nothing happens.

    This works fine when using Adobe XD (13.0.12.14) on a physical host.

    1 vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  7. Artboard Not Showing in Windows 10

    Work area is blank no artboard is showing in windows 10.

    2 votes
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    resolved-by-setting-update  ·  6 comments  ·  Flag idea as inappropriate…  ·  Admin →
  8. Can't install XD CC from restricted user.

    Can't install XD CC from restricted user. After priviliges prompt the error is Installation failed. When i installed on admin account the rest of users don't see the app in CC app panel.

    1 vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  9. Wacom Pen doesn't work without Mouse Click

    1. Version:13.0.12.14 (windows os)
    2. Open Xd , press space bar to activate the hand tool to move the canvas around and I'm unable to. This also happens when I switch from XD to the browser window then back to XD. I am unable to use the pen tool without an initial click of the mouse.
    3. I expect to see the hand tool (once the space bar is down) and to be able to move my canvas without the assistance of the mouse.
    4. Cursor arrow changes color from black to white and I am unable to move my…

    1 vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  10. Large white box masks my shared prototype

    My link is not well displayed, a huge white box masks my photos !
    What is the problem ? Thank u!

    1 vote
    Sign in
    (thinking…)
    Sign in with: facebook google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Adobe XD: Bugs

Feedback and Knowledge Base