Adobe XD: Bugs (Read-Only)

PLEASE NOTE THE FOLLOWING CHANGE FOR BUG REPORTS

IMPORTANT: User Voice Bugs forum is now read-only. To learn more about this change, visit https://adobexd.uservoice.com/forums/353010/suggestions/38475424

You can reach our support team in the following:
- Adobe XD Community Forum, https://forums.adobe.com/community/adobexd

For current XD Known Issues list visit,



Thank you!
Adobe XD Team


  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Prototype

    1) Version: 14.0.42.14
    2) While prototyping major effort is disappeared. In 1st picture we dont know how many Art boards are being selected and are linked.In the 2nd image i could only see only 1/4 screen but as per 1st image more than 4 screens are linked. There could be an option showing "No of Art boards are being linked". So, that we dont have to manually account the Artboard every time to re-confirm in the Prototype link.
    3. Knowing no.of linked artboards would help before creating a Sharing link so that we dont miss out on any artboard
    4.…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    not-a-bug-as-designed  ·  1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  2. Mask animation not showing on prototype

    As you can see in the video. The masked animation of a button-progressbar shows properly within adobe xd and on the video however on the prototype it doesn't display properly or at all.

    https://xd.adobe.com/view/8e2bc891-8b05-4fb4-7ae1-42d3efac2819-f81a/

    I tested in chrome, safari and firefox. all latest version as of today.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  3. Outgoing and ingoing Wiring in prototype mode are all in the same color

    In the past, selecting an artboard showed outgoing wiring links in blue.
    Now all wiring in the same color which make it hard to distinct between the outgoing and ingoing wiring links

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    not-a-bug-as-designed  ·  1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  4. 'Reset to master' component drops prototype links from master

    If you choose 'Reset to master' from a child component, it breaks/drops any prototype links that are on the master and on the child. This should not be the case. The master component should be the 'source of all truth' for design AS WELL AS prototype linkage. So when you 'Reset to master' from a child component it should pick up all prototype links from the master and attached them to the said child instance.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →

    Hi James,

    Sorry to be a little late getting back to this, and thanks for the extra information and file.

    As I referred to in my first reply, what we make sure to do is to not lose any existing links on an instance when you reset it to master, and that is indeed the case. Prototype linking Is not a property of components, but a document-specific action that is applied to an instance in Prototype mode, so it’s not something that could be retained as part of the component definition as it is today.

    Regarding your idea for making a link on a master component link a property of the component definition (or something similar), please feel free to log a feature request here in UserVoice for what you had in mind. Keep in mind that although components are defined at the document level, linked components can be made from…

  5. Delay option has been vanished form Prototype Mode

    After the latest update of Adobe XD I has come to notice that there is no delay option in the interaction area. In previous versions I always found it under Duration input. Please have a look. This is horrible!

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    not-a-bug-as-designed  ·  1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  6. Xbox One Controller Xbox Button Doesn't Register when pressed.

    XD Version: 19.0.22.9
    Mac OS: 10.14.5
    Computer: iMac (21.5" Late 2012)

    I expect the Xbox Button to be able to be used in prototypes, but it doesn't register when pressed. All other buttons on the controller are fine, as are all DS4 Buttons, including the PS Button. This just seems like a little oversight.

    I've attached a file to demonstrate my issue, hopefully this is an easy fix!

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    not-a-bug-as-designed  ·  1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  7. Auto-Animate Layout bounding bug

    If the object(layer) which is set to be animate on artboards with auto-animate changes the scroll position then it does not work as expected.

    It seems that the object(layer) is not bounding to the artboard layer.
    Please check this.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  8. include assets button grayed out

    I've used the "Include Assets" feature before, but for some reason, it's grayed out (I can not select the "Include Assets" button); all my assets are selected for batch. Can you please help me?

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →

    Hello Rica-Marie:

    Looking at the file you shared with me I see what’s going on. When artboards are selected for batch export, that ignores the items inside the artboard for asset inclusion.

    See below steps for how to use this from Harish Narayan, Product Manager for Design Specs.

    Thanks!
    Nina

    Please follow the below steps to successfully include assets in Design Specs

    1. Open the layer panel (View>Layers)

    2. The layers panel is contextual and either shows the list of all artboards or the list of all layers in the selected artboard.

    3. Make sure that you are seeing the list of layers on a selected artboard. i.e. Click on any layer in the canvas or double click on the artboard name in the layers panel

    4. Now hover over the layers that you want to pass off as assets to the developer and click on the “Mark for Batch…

  9. auto animate bug

    the auto animate dose not move content to correct location when content is bigger than art board.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  10. No time transition in trigger dropdown

    Hello, after I update the latest patch (13.0), I can't see the time button in trigger dropdown for the transition. Is that a bug?

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →
  11. Animation dropdown menu issue


    1. Adobe Xd 12.0.12.10 (Starter). S.O.: Windows 10 Home.


    2. I'm working on a project that currently has 3 artboards: Inicio, Proyectos and Detalle. The issue takes place when I try to link one of the projects thumbnail (located in the artboard "Proyectos") to Detalle. The animation dropdown menu is disabled with "dissolve" as the only option available.


    The same happens on the artboard "Detalle". When I try to link Inicio and Proyectos to their correspondent artboards, I'm only given the option "Dissolve".

    I'll attach the file so you can analyze it.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →

    Greetings!

    Thanks for sharing your project! I can immediately see where things are stuck. You’ve encountered something that is working as expected. Currently, when connecting artboards of different sizes, the only transition that will be available is dissolve.

    To access the rest of the transition options, you should make ‘Detalle’ artboard have same width as the others (1920). Currently it’s set to 1912.

    Cheers!
    Nina
    Adobe XD

  12. Exit from fullscreen mode in prototype on browser

    There is no option to exit from the full-screen mode in shared prototype view on the desktop browser

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Prototype  ·  Flag idea as inappropriate…  ·  Admin →

Feedback and Knowledge Base