Adobe XD: Bugs (Read-Only)

PLEASE NOTE THE FOLLOWING CHANGE FOR BUG REPORTS

IMPORTANT: User Voice Bugs forum is now read-only. To learn more about this change, visit https://adobexd.uservoice.com/forums/353010/suggestions/38475424

You can reach our support team in the following:
- Adobe XD Community Forum, https://forums.adobe.com/community/adobexd

For current XD Known Issues list visit,



Thank you!
Adobe XD Team


  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Transitions not doing what they say

    If you made a dissolve transition from one page to another, and then a slide transition on different pages, they only act as dissolve transitions. It also converted other, already set, transitions into dissolves.

    4 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  2. Object blur effect has slow performance sometimes


    1. 0.5.6.7 beta

    2. Step
      1) draw a rectangle (100 x 100)
      2) set color and enable object blur(40)
      3) copy the rectangle and change fill color
      4) mask those renctagles with shape
      5) move the object

    3. Moving the group is smooth as usual.

    4. I feel moving the group is very heavy

    5. please try to move the 4th button in the attached file.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  3. Pen tool should draw paths on whole pixels (no fractions - pixel aligned/snapped)

    It's impossible to draw and align perfectly all elements with the comma in x and y position and also Height and width of all single objects

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  4. zoom is broken during sharing upload

    Version of Adobe XD 0.5.4.51 Beta

    Steps to reproduce the issues
    1 Open a prototype
    2 Share online
    3 New link
    4 while it shares (1 to 3 hours in current version) try to zoom in or out with the magic mouse

    Expected result regular zooming
    Actual result

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  5. I can't share prototype online. Help!

    I created a file which became pretty big. It has lots of artboards and pictures. I can't get it to share online. The file is 61 mb. It doesn't happen with smaller files.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  6. Copy/Paste from Illustrator broken in latest version (0.5.6.7)

    In the previous version of XD I could easily copy/paste from Illustrator. With the new version: 1st the pasted content is not complete (graphic elements are missing), 2nd the appearance of elements is not the same (line strokes and transparency doesn't get carried).

    Sad, as this was working perfectly in the previous version.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  7. Exported SVG Icons cause problems with every icon font generator

    I've exported SVG Icons, some using boolean operations, some using compound paths I think. For reference, check out some svg icons from the official material design list.

    I've tried several icon font solutions right now. The icons just display horribly. If I open the svg in illustrator and re-save it, it'll work fine. I am suspecting the svg syntax doesn't work. Is this standard compliant? Too bleeding edge syntax for these tools?

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Flag idea as inappropriate…  ·  Admin →
  8. Protoype Page Scrolling not consistant

    version 0.5.4.51 built a 7 page doc and page 3, 4, and 7 requiring scrolling and it works and scrolls great on pages 3 and 4. however page 7 will not scroll is there a limit to the scrolling feature? page 7 links i have set work but the scrolling feature does not. i tried rebuilding the page and resetting the links. i viewed in preview as well as share on line with the same result no scrolling feature on this last page.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Flag idea as inappropriate…  ·  Admin →
  9. Font Awesome Icons not visible after upgrade.

    After upgrading to Preview 2 all Font Awesome Icons are no longer visible. This appears to be a text box sizing issue. Upon expansion of the text box bounds, the icon is visible, but is not aligned correctly.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  10. lock doesn't display correct coordinates

    When an element is locked, the y axis goes negative and the x axis is incorrect. This is when an element is locked and I click on it to see the context menu. When I unlock it and see the context menu again its correct, but I have to unlock it. Sometimes I just need to see the position without moving the object.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  11. Grouped elements align when resizing

    When you have some grouped elements (i.e. icon-text icon-text) and you copy them (I suppose it should work without copying) and resize the whole group of those elements, their alignmed gets messed up.

    For example, I have two elements:
    1. icon
    2. text

    Icon is above text and is centered to text. When I resize all group icon gets moved to one of the sides, gets decentered.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Flag idea as inappropriate…  ·  Admin →
  12. Transition between Screens: seam / thin line visible

    I have many screens and they are all the same background color, without any border or stroke. When I move between screens (Slide up or down) in the preview, it seems like there IS a stroke between screens while actually it should be a smooth transition

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  13. Font styles/colors all changed on first launch after April update

    I updated AdobeXD today, and upon opening an existing product, found that all the font styles and colors had been changed. For example, everything that was Proxima Nova regular was not light italic. I was worried I'd have to manually go through and change everything back, but closing the file and opening it again fixed the issue.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Flag idea as inappropriate…  ·  Admin →
  14. Font reverting to Helvetica after altering and saving to different font

    I've been making an app mockup for about a week and I've tediously changed all the font throughout the app to be one uniform font. When I launch the app it all reverts back to Helvetica and I dont want to go through the whole prototype and change it again. Thanks

    8 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Flag idea as inappropriate…  ·  Admin →
  15. 1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  16. Displaying Garbage Characters (for certain fonts only)

    This has happened to me a few times, I'm not sure if I'm doing something wrong or if it could possibly be a bug. XD has displayed garbage characters intermittently. It has happened when I've used the Lato or Roboto font family. I use Suitcase Fusion 6 to manage my fonts. I have tried a few things. Deactivating then activating fonts, exiting XD then opening it up again. Sometimes it has solved the problem, most times XD has continued to display garbage characters. I've attached a screenshot. My original design used Lato Bold and it seems that XD will render…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  17. XD doesn't recognize XD file.

    Adobe XD Version 0.5.0.4

    Steps: Create an XD file, save it, then close it. Open again about a minute later.
    Expected result: Opening the project.
    Actual Result: I got the message: "Error loading document. Invalid document type".

    I tried to add the extension .xd manually. Still didn't open.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  18. Error 1124 in Adobe XD


    1. This service is unavailable right now (error 1124). Check our system status page for known issues.


    2. It happened right after I clicked on the Share Link icon.


    3. 21 artboards. 53KB file.


    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  19. Art board deletes paste board content when dragged over it.

    In the design tab when I move the art boards around, any content on the paste board vanishes when the art board passes over or is placed on it. I don't know if there is a way to "bump" paste board content out of the way but that would be awesome!

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  20. Scaling UI Kit objects

    After horizontal / vertical scale the rounded corners are strange.

    Eg. scale the android button to 300 width

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →
1 2 7 8 9 11 Next →

Feedback and Knowledge Base