Adobe XD: Bugs (Read-Only)

PLEASE NOTE THE FOLLOWING CHANGE FOR BUG REPORTS

IMPORTANT: User Voice Bugs forum is now read-only. To learn more about this change, visit https://adobexd.uservoice.com/forums/353010/suggestions/38475424

You can reach our support team in the following:
- Adobe XD Community Forum, https://forums.adobe.com/community/adobexd

For current XD Known Issues list visit,



Thank you!
Adobe XD Team


  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Cannot drag layers that are inside a masked group

    It is currently not possible to drag a layer to change its position in the layer panel if the object is within a masker group (includes repeat grids).

    I'm already used to using the Ctrl [ and ] shortcut to move layers up and down, but I still find myself sometimes dragging the layer out of convenience and forgetting it doesn't work. I also see other users often mention the same issue.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  2. ALt + drag to duplicate artborad doesn't work only on one particular artboard

    Version of XD i'm using is 19.1.22.6/
    For some reason I'm not able to alt+drag one specific artboard to duplicate it.
    Undo function is also disabled. Not sure if it got something to do with issue with duplicating artboard but it started to happen at the same time. I have to say, that other documents, as well as other ARTBOARDS in this particular document work just fine.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  3. Save discards changes

    Added 20 prototype links on reapeatgrid atoms towards overlay modal.
    Manual save, switch to design mode, edit, back to prototype mode, changes lost.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  3 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  4. Unable to drag layers of elements or components


    1. Version 21.2.12.3 (Starter) running on Windows 10 Home.

    2. Keep left mouse button pressed while hovering a component or element layer to move (drag).

    3. Rearrange layers, drop them into an existing folder or artboard in case of components.

    4. Nothing happens. Layers remain static.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  5. Adobe XD for Jira 2.0 not functional on service desk projects

    Error reads: "Hmm, there seems to be a problem adding this link."

    Is this new version release and bug due to "new view" changes in Jira on other project types (not service desk ones currently)?

    Are there workarounds for this drop of functionality?

    Thanks!

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    third-party-plugins  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  6. Error code 88

    Cannot open file

    There was an error opening the file Untitled-2.xd.
    This is not a valid xd document.

    XD version provided in the screenshot attached.

    Windows 10 operating system

    The files were saved in the my own system.

    impact- the saved work cannot be retrieved.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  3 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  7. Undo and save option stop working after movig elements to different artboard

    Undo option dissapears as well as save (only save as stays) after alt+move element from one artboard to another.

    version 21.2.12.3

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  8. Shortcut CMD + - stop working after update on version 19

    Zooming shortcuts stopped working on new version 19 of XD. Classic key +/- works well, but Numlock keys +/- stopped working. Using iMac.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  4 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  9. undo

    Undo and redo are not working. Also, I can't copy an item with option + drag like I'm used to.

    I have the lastest version of XD (20.0.12.10). I've reset the computer, restarted XD, saved my file to both cloud and desktop, logged out of CC and logged back in, quit CC and restarted. It's still doing this.

    You never really realize how essential Cmd Z really is until it stops working.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-needs-more-info  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  10. Jira user with apostrophe has page update issue with Adobe XD add-on

    We experience an issue with Adobe XD for Jira add-on.
    We believe the issue is potentially caused by apostrophe in Jira username.

    After installing the add-on, this particular user sees page ‘freezing’ whenever she updates the ticket such as comment.
    The comment gets published, but she has to refresh page to see the update.

    She can reproduce the issue on two different machines (MacOS, Windows) with different browsers.
    Below is the error message in console log.

    Note, when we disable the add-on, the issue goes away.

    Jira version: 7.13.0
    Jira Core version: 7.13.0

    2 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  11. Suddenly missing fonts

    I was working on an Xd file. Had to do a "hard" power down of my laptop. After restarting, it's showing both in my Cloud library and the file using library Roboto is missing.

    I've checked Typekit and it's showing my fonts are activated.

    What am I missing?

    Thanks!
    Jason

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  12. Cannot move or add the layers in the components

    Once I created component, made a repeat grid, it was not allowing me to adjust the layers within the component or even add a new layer to the component.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  13. Adobe XD uses Mobile Data vs WiFi

    I have a problem/bug. I was working in Live Preview Adobe XD (iPhone X App) with turned on WiFi (!) and mobile data (on iPhone X) and connected to my Desktop PC via USB (Windows 10). And after some time, I have received a message from my mobile carrier that my mobile data reached 100% for this month. I know this is impossible because there was plenty left. I know this was used by Adobe XD. I'm in the process of switching from Photoshop to XD. And this is the only new thing I was using this month.

    About the…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  14. Dragging elements off artboard become hidden (intermittently)

    Weird issue I noticed happening the other day, and again just now. Some elements stay linked to the artboard they previously occupied even after I've dragged them off. I don't always notice this has happened, until I select an artboard and notice elements surrounding it suddenly appear, then disappear when the artboard is deselected.


    1. Version 15.0.12.8


    2. Select an element and drag it off an artboard.


    3. I expect the element to stay visible; I expect the element to stay visible even though it is not attached to an artboard.


    4. Sometimes the selected/dragged element immediately becomes hidden, even when its borders are…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  8 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  15. Drop shadow ruins image quality when exporting to pdf/svg

    When I'm trying to export my XD file in a pdf or SVG format it ruins the quality of the shape or image if I use a drop shadow. If I remove the shadow, the quality is maintained. Can you fix this problem somehow?

    Adobe XD version: 21.0.12.11

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  16. Assets, color picker is missing

    I just install Adobe XD 19.1.22.6
    and follow the introduction tutorial (in app and video)

    In step 09, I notice that in the asset panel, when right click on a color and select "Edit", there is no more the color picker (pipette icon).

    I guess that would be handy to put it back.

    3 votes
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  17. Cannot copy elements to other documents. Some documents don't register changes and Undo/Redo doesn't work. in latest XD update22 Aug 2019.

    Cannot copy elements to other documents. Some documents don't register changes and Undo/Redo doesn't work. in latest XD update22 Aug 2019.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  18. Save as new document automatically autosaves the previous document

    Saving the current project as a new one after making changes automatically trigers saving the current changes to both of the files.

    Steps to reproduce:


    1. Open up a project (for example "document.xd")

    2. Make some changes

    3. Save it as "document_alternative.xd"

    4. Both - document.xd and document_alternative.xd are now the same file

    In every other app from the CC, the "Save as" feature is saving just the new instance of the document, and automatically lets you work with it. The previous one is not updated. Is it a design? If so it can be really misleading, I have lost a lot of my…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  19. Aspect ratio is correct but it won't fit to screen when using mobile preview app

    when I have a 360x640 artboard it has the exact same aspect ratio as a 1080x1920 phone. however when viewing the proto on that phone, or any of several phones that match that aspect ratio, the artboard doesn't fit to the screen, and instead all the way around the board it leaves a black space.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →
  20. Exporting to After Effects issues

    I'm having problems with how objects are rendered in AE after export from XD.


    1. Objects with gradients are converted to JPGs

    2. Blurred object with gradient applied doesn't show up at all

    3. Shadows are rendered differently than in XD (different blur and radious)

    4. Shadows and low opacity objects don't show up in preview in AE

    1 vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)

    We’ll send you updates on this idea

    bug-filed  ·  2 comments  ·  Functional  ·  Flag idea as inappropriate…  ·  Admin →

Feedback and Knowledge Base