Request details

Direct selection must ignore invisible layers

When you Ctrl+click to do direct selection then you also select layers with 0% opacity, which means that you are not selecting what you see.

With Auto Animate I have begun to place layers on top of each other, and in next artboard move them into final position to simulate foldout. This will also transition from 0 to 100% opacity, which is why I don't simply hide the layers.

This makes it difficult to edit what is visible and layered behind the top layers of 0% opacity.
E.g. if I then want to edit a text field then I cannot access it as it is behind 3 other layers of 0% opacity. As text doesn't have its text value available in the right-hand properties panel then I actually cannot edit the text string in any other way than hide the above layers, and then double-click the text on the artboard. Bonus idea: double-click the icon of a text layer could highlight the text in the artboard.

2 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Jesper Simonsen shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • AdminRandy Edmunds (Software Engineer, Adobe) commented  ·   ·  Flag as inappropriate

    Thanks for sending in detailed feature requests!

    > Bonus idea: double-click the icon of a text layer could highlight the text in the artboard.

    For now, you can select the text layer and then hit Enter key to highlight the text for editing.

    Hope this helps,
    Randy

Feedback and Knowledge Base